Support Questions
Find answers, ask questions, and share your expertise

hcat client install failure with Ambari 2.6

Solved Go to solution

Re: hcat client install failure with Ambari 2.6

@sk kumar,

Did u try running the steps @bmasna has mentioned. That should work

Re: hcat client install failure with Ambari 2.6

New Contributor

@sk kumar,
How did you fixed the issue with zookeeper?

Re: hcat client install failure with Ambari 2.6

Thanks, @Aditya Sirna. I've just tried that. It worked.

Thanks @bmasna it worked for me.

Re: hcat client install failure with Ambari 2.6

New Contributor

Hello,when I install Ambari 2.6,the zookeeper version is not Available,there notes:

=======================================================================================

stderr: /var/lib/ambari-agent/data/errors-29.txt
2018-10-28 22:45:43,494 - ============lljjyy1 2.6.5.0
2018-10-28 22:45:43,494 - ============lljjyy2 2.6.5.0
2018-10-28 22:45:43,494 - ============lljjyy3 2.6.5.0
2018-10-28 22:45:45,497 - The 'zookeeper-client' component did not advertise a version. This may indicate a problem with the component packaging.
Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/common-services/ZOOKEEPER/3.4.5/package/scripts/zookeeper_client.py", line 79, in <module>
    ZookeeperClient().execute()
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 375, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/common-services/ZOOKEEPER/3.4.5/package/scripts/zookeeper_client.py", line 59, in install
    self.install_packages(env)
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 812, in install_packages
    name = self.format_package_name(package['name'])
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 547, in format_package_name
    raise Fail("Cannot match package for regexp name {0}. Available packages: {1}".format(name, self.available_packages_in_repos))
resource_management.core.exceptions.Fail: Cannot match package for regexp name zookeeper_${stack_version}. Available packages: ['openblas', 'openblas-Rblas', 'openblas-devel', 'openblas-openmp', 'openblas-openmp64', 'openblas-openmp64_', 'openblas-serial64', 'openblas-serial64_', 'openblas-static', 'openblas-threads', 'openblas-threads64', 'openblas-threads64_', 'snappy', 'snappy-devel', 'snappy-devel']
stdout: /var/lib/ambari-agent/data/output-29.txt
2018-10-28 22:45:43,032 - Stack Feature Version Info: Cluster Stack=2.6, Command Stack=None, Command Version=None -> 2.6
2018-10-28 22:45:43,035 - Group['hadoop'] {}
2018-10-28 22:45:43,036 - User['zookeeper'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop'], 'uid': None}
2018-10-28 22:45:43,036 - User['ams'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop'], 'uid': None}
2018-10-28 22:45:43,037 - User['ambari-qa'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['users'], 'uid': None}
2018-10-28 22:45:43,037 - File['/var/lib/ambari-agent/tmp/changeUid.sh'] {'content': StaticFile('changeToSecureUid.sh'), 'mode': 0555}
2018-10-28 22:45:43,038 - Execute['/var/lib/ambari-agent/tmp/changeUid.sh ambari-qa /tmp/hadoop-ambari-qa,/tmp/hsperfdata_ambari-qa,/home/ambari-qa,/tmp/ambari-qa,/tmp/sqoop-ambari-qa 0'] {'not_if': '(test $(id -u ambari-qa) -gt 1000) || (false)'}
2018-10-28 22:45:43,044 - Skipping Execute['/var/lib/ambari-agent/tmp/changeUid.sh ambari-qa /tmp/hadoop-ambari-qa,/tmp/hsperfdata_ambari-qa,/home/ambari-qa,/tmp/ambari-qa,/tmp/sqoop-ambari-qa 0'] due to not_if
2018-10-28 22:45:43,056 - Repository for HDP/2.6.5.0/HDP-2.6 is not managed by Ambari
2018-10-28 22:45:43,057 - Repository for HDP/2.6.5.0/HDP-2.6-GPL is not managed by Ambari
2018-10-28 22:45:43,057 - Repository for HDP/2.6.5.0/HDP-UTILS-1.1.0.22 is not managed by Ambari
2018-10-28 22:45:43,057 - Package['unzip'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2018-10-28 22:45:43,178 - Skipping installation of existing package unzip
2018-10-28 22:45:43,178 - Package['curl'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2018-10-28 22:45:43,233 - Skipping installation of existing package curl
2018-10-28 22:45:43,233 - Package['hdp-select'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2018-10-28 22:45:43,291 - Skipping installation of existing package hdp-select
2018-10-28 22:45:43,343 - call[('ambari-python-wrap', u'/usr/bin/hdp-select', 'versions')] {}
2018-10-28 22:45:43,363 - call returned (0, '')
2018-10-28 22:45:43,494 - ============lljjyy1 2.6.5.0
2018-10-28 22:45:43,494 - ============lljjyy2 2.6.5.0
2018-10-28 22:45:43,494 - ============lljjyy3 2.6.5.0
2018-10-28 22:45:43,494 - Command repositories: HDP-2.6, HDP-2.6-GPL, HDP-UTILS-1.1.0.22
2018-10-28 22:45:43,494 - Applicable repositories: HDP-2.6, HDP-2.6-GPL, HDP-UTILS-1.1.0.22
2018-10-28 22:45:43,496 - Looking for matching packages in the following repositories: HDP-2.6, HDP-2.6-GPL, HDP-UTILS-1.1.0.22
2018-10-28 22:45:45,422 - No package found for zookeeper_${stack_version}(zookeeper_(\d|_)+$)
2018-10-28 22:45:45,478 - call[('ambari-python-wrap', u'/usr/bin/hdp-select', 'versions')] {}
2018-10-28 22:45:45,497 - call returned (0, '')
2018-10-28 22:45:45,497 - The 'zookeeper-client' component did not advertise a version. This may indicate a problem with the component packaging.

Command failed after 1 tries
==================================================================================================
Can you help me?

Re: hcat client install failure with Ambari 2.6

Cloudera Employee

@Li Jiayan Can you try below change and try to install.

Edit "/usr/lib/python2.6/site-packages/resource_management/libraries/script/http://script.py" python script and comment line "package_version = None" (line# 541).

Re: hcat client install failure with Ambari 2.6

New Contributor

When I installed HDP-GPL before, I used my own local Yum source. I solved it by default. Thanks.

Re: hcat client install failure with Ambari 2.6

Cloudera Employee

@Aditya Sirna & @sk kumar .Good to know it worked for you :)