Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

hcp-1.7.1 metron-alerts-ui bug

Highlighted

hcp-1.7.1 metron-alerts-ui bug

New Contributor

Under CentOS7 there's a bug which prevents metron-alerts-ui from starting.

In /etc/rc.d/init.d/metron-alerts-ui, METRON_HOME is set to:

METRON_VERSION=0.6.0.1.7.1.0-24
METRON_HOME=/usr/metron/$METRON_VERSION

It should be set to:

METRON_HOME=/usr/hcp/current/metron
7 REPLIES 7

Re: hcp-1.7.1 metron-alerts-ui bug

Super Collaborator

Hi @David Auclair, can you check the contents of /etc/default/metron and the value for 'METRON_HOME' in that file?

So, in the /etc/rc.d/init.d/metron-alerts-ui file, the above file is sourced (see this link) which sets the proper METRON_HOME variable.

Re: hcp-1.7.1 metron-alerts-ui bug

New Contributor

I got the error of alert UI, after change the value 'METRON_HOME' on

 /etc/rc.d/init.d/metron-alerts-ui 
based on
/etc/default/metron 
, the service start but died in a few minute. The things that i do was start the alert UI and restart the service before it died. The alerts ui now its running.

Re: hcp-1.7.1 metron-alerts-ui bug

New Contributor

Can you help me about HCP 1.7.1 installation ?

I try to Install HCP 1.6.1 on single node ( Centos 7 ) but in ambari-server web I can't see Metron & Elasticsearch & Kibna Serivce for select and installation.

Is it possible to install HCP 1.7.1 in single node ?

Re: hcp-1.7.1 metron-alerts-ui bug

New Contributor

sorry @haco fayik, the version of HCP of mine is 1.6.0, currently do some testing on it.

Re: hcp-1.7.1 metron-alerts-ui bug

New Contributor

Hi @Amirul, version is not important for me . can you tell me about your HCP environment ( Number of Server, OS , etc ) ?

I need to help about HCP Installation ( 1.7.1 or 1.6.0 or ect )

Thanks

Re: hcp-1.7.1 metron-alerts-ui bug

New Contributor

yes, hello @haco fayik,

I'm using single node installation with Centos 7.

Ambari version 2.6.2 with (HCP 1.6.0 and Elasticsearch 1.6.0) mpack's

Re: hcp-1.7.1 metron-alerts-ui bug

New Contributor

Thanks @Amirul ,

I try to install HCP 1.6.0 on Centos 7 but in ambari server metron and elasticsearch services not exist. I have same problem in installation HCP 1.7.1 . please see my question in below link :

https://community.hortonworks.com/questions/229345/problem-in-installing-hcp-171-using-ambari.html

---

finaly can you provide Installation guide with details ( Step by Step from OS installation and hardware requirements - software installation and etc ) ?

Don't have an account?
Coming from Hortonworks? Activate your account here