Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

hdp 3.0.1 upgrade from 2.6.3 pre-requisite

hdp 3.0.1 upgrade from 2.6.3 pre-requisite

New Contributor

The pre upgrade tool is reporting error

requires Hive 2.x. Actual: 1.2.1000

I have Hive Interactive enabled and confirms to this thread

https://community.hortonworks.com/questions/55051/no-hive-21-in-hdp-25.html

I don't have ACID tables in Hive.

Is it OK if I go ahead with version upgrade from Ambari without running pre-upgrade tool? Will it upgrade Hive?

Kindly let me know

2 REPLIES 2

Re: hdp 3.0.1 upgrade from 2.6.3 pre-requisite

New Contributor

Since we did not have ACID tables, it worked without pre-upgrade tool.

Re: hdp 3.0.1 upgrade from 2.6.3 pre-requisite

New Contributor

I am also facing the same issue is there any solution for it, or we can ignore this exception.

I have upgraded a database MariaDB from 5.6 to 10.2 and Ambari 2.6.2.2 to 2.7.3.
Getting an error while running the hive pre-upgrade check.

2019-07-04 03:07:47,604 ERROR [main] acid.PreUpgradeTool (PreUpgradeTool.java:main(153)) - PreUpgradeTool failed

java.lang.IllegalStateException: preUpgrade requires Hive 2.x. Actual: 1.2.1000

at org.apache.hadoop.hive.upgrade.acid.PreUpgradeTool.main(PreUpgradeTool.java:148)