Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

hive shell is not being invoked

hive shell is not being invoked

New Contributor

when i try to invoke the hive shell in the command line it is not showing up. error is popping up with an exit code = 1, tez session not running, and exception in the container launch. hive.png

6 REPLIES 6

Re: hive shell is not being invoked

@pk reddy

When Hive Cli is invoked, it initializes a Tez application. Seems like the AM container launch has some issues. Check the Resource Manager log for the same.

To launch Hive Cli without Tez session initialization, try either of the below commands:

hive --hiveconf hive.execution.engine=mr

or

hive --hiveconf hive.server2.tez.initialize.default.session=false

Re: hive shell is not being invoked

New Contributor

i am able to invoke hive usign mr but i want the exec engine as tez, even i tried to use the tez engine after invoking hive by setting set hive.execution.engine-tez, it is still not working.hive1.png

Re: hive shell is not being invoked

@pk reddy

Please check /tmp/<user_name/hive.log and also, RM log for issues with respect to tez session launch.

Re: hive shell is not being invoked

New Contributor

@Sindhu

i was succesful in launching the tez engine but now i am getting an error of java lang runtime exception : java outofmemory : java heap size. i tried giving some more memory for the java heap size but it still the task is failing. indhu

Re: hive shell is not being invoked

Rising Star

@pk reddy give enough memory to tez AM container. tez.am.resource.memory.mb

Re: hive shell is not being invoked

@pk reddy

When is the OOM issue seen, during the launch of Hive Cli or query run?

Try below hive --hiveconf hive.tez.container=4096