Support Questions

Find answers, ask questions, and share your expertise

hiveserver2 not starting (Node does not exist: /hiveserver2)

New Contributor

Hi

I have done a fresh install of hdp 3.0.0 on a cluster of 5 servers .

Everything seems to be OK, except hiveserver2 which refuses to start

Logs says it's because of an inexistent /hiveserver2 znode on the zookeeper cluster.

Here is the log hiveserver2log.txt

I tried to delete then recreate the service hoping that it would initialize the znode without success.

Any one can help ?

Thanks

6 REPLIES 6

@Nicolas Zagulajew can you provide any more details or specifics for what you are experiencing?

New Contributor

I edited the text.

Hello @Nicolas Zagulajew!
Do you see anything inside the zk namespace under the Hiveserver path? To do it, you can execute the following command:

[root@node3 ~]# zookeeper-client
[zk: localhost:2181(CONNECTED) 0] ls /hiveserver2
[serverUri=node3:10000;version=1.2.1000.2.6.5.0-292;sequence=0000000001]
And could you confirm if the following properties were set properly?
hive.cluster.delegation.token.store.zookeeper.connectString
hive.cluster.delegation.token.store.zookeeper.znode
hive.server2.support.dynamic.service.discovery
hive.server2.zookeeper.namespace
hive.zookeeper.quorum

Hope this helps!

New Contributor

There was nothing at all.. Even the /hiveserver2 was not present.

I had not realized that /warehouse was on HDFS and not on a server filesystem, I changed it to /var/opt/warehouse on install to put it on another filesystem.

I reinstalled the whole thing without to this change and it worked.

Thanks for your time.

New Contributor

I have the same issue, can you explain how you resolve it in more detail (how do you change /warehouse location), it will be highly appreciated 🙂 Thanks 🙂

Hello @Pierric Ruchier!
You can change the default /warehouse location by setting the following parameter:

hive.metastore.warehouse.dir

Also, don't forget to point to a dir with permission to your user.

Hope this helps!

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.