Support Questions
Find answers, ask questions, and share your expertise

how to add kdc validation attributes in hadoop server services rest api url response. Please go through description

Explorer

I have kerberos enabled hadoop ambari server and its component ex. datanode ,namenode or YARN etc etc are kerberized but its services rest api url is not kerberized .

while hitting url -

http://host:8080/api/v1/clusters/<ClusterName>/services/<Service NAME>

 

I can see below properties in response -

"kerberos_enabled" : false,
    "maintenance_state" : "OFF",
    "repository_state" : "CURRENT",
    "service_name" : "HDFS",
    "sso_integration_desired" : false,
    "sso_integration_enabled" : false,
    "sso_integration_requires_kerberos" : true,
    "sso_integration_supported" : true,


I want to enable kerberos for above url  .

 when I hit the rest api url for kerberos service 

http://host:8080/api/v1/clusters/<ClusterName>/services/KERBEROS

 

I can see below in response -

"Services" : {
"attributes" : {
"kdc_validation_failure_details" : "Missing KDC administrator credentials.\nThe KDC administrator credentials must be set as a persisted or temporary credential resource.This may be done by issuing a POST to the /api/v1/clusters/:clusterName/credentials/kdc.admin.credential API entry point with the following payload:\n{\n \"Credential\" : {\n \"principal\" : \"(PRINCIPAL)\", \"key\" : \"(PASSWORD)\", \"type\" : \"(persisted|temporary)\"}\n }\n}",
"kdc_validation_result" : "MISSING_CREDENTIALS"
}
}
 
I want resolve this response issue and also enable kerberos for ambari services rest api url's.
 
Please suggest and help for above cases.
0 REPLIES 0