Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

how to set up LZO compression on CM 5.4.0? after activating GPLEXTRAS cluster fails to restart.

how to set up LZO compression on CM 5.4.0? after activating GPLEXTRAS cluster fails to restart.

New Contributor

Hello,

 

I have setup the cluster using CM 5.4.0 using package installation. I want to set up the LZO compression on it. Followed this instructions. But after activation cluster fails to deploy client configuration and it fails to restart. Any idea? I have setup the cluster originally using packages not parcels.

Is this an issue?

 

Thank You!

4 REPLIES 4

Re: how to set up LZO compression on CM 5.4.0? after activating GPLEXTRAS cluster fails to restart.

Have you installed the lzo RPM as mentioned in the document? What error are
you facing? Please provide a screenshot or the exact error message

Regards,
Gautam Gopalakrishnan

Re: how to set up LZO compression on CM 5.4.0? after activating GPLEXTRAS cluster fails to restart.

New Contributor

I did

 

sudo yum install lzo

Loaded plugins: amazon-id, rhui-lb, security
Setting up Install Process
Package lzo-2.03-3.1.el6_5.1.x86_64 already installed and latest version
Nothing to do

  Here is the screenshot

error.png

 

Re: how to set up LZO compression on CM 5.4.0? after activating GPLEXTRAS cluster fails to restart.

Sorry for the delay here. Are you able to tell us how HDFS is failing to
start? You should be able to click the "details" link and follow it down to
the "role log" where the entire error message would be.

Regards,
Gautam Gopalakrishnan

Re: how to set up LZO compression on CM 5.4.0? after activating GPLEXTRAS cluster fails to restart.

New Contributor

Hi Gautam,

 

Thank you for you response!!

My apologies for late reply as our cluster was so busy last month, did not get chance to work on this issue.

After installing LZO parcel when I restart the cluster name node service fails to restart.

From all namenode's log details I get this. Also NFS Gateway service is failing to start.

 

 

8:40:48.952 AMINFOorg.apache.hadoop.hdfs.server.namenode.top.window.RollingWindowManager

topN size for command listCacheDirectives is: 1

8:40:48.953 AMINFOorg.apache.hadoop.hdfs.server.namenode.top.window.RollingWindowManager

topN size for command listStatus is: 3

8:40:48.953 AMINFOorg.apache.hadoop.hdfs.server.namenode.top.window.RollingWindowManager

topN size for command getfileinfo is: 3

8:40:48.969 AMERRORorg.apache.hadoop.hdfs.server.namenode.NameNode

RECEIVED SIGNAL 15: SIGTERM

8:40:48.975 AMINFOorg.apache.hadoop.hdfs.server.namenode.NameNode

SHUTDOWN_MSG: 
/************************************************************
SHUTDOWN_MSG: Shutting down NameNode at XXX
************************************************************/