Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

install knox error. IndexError: list index out of range

Highlighted

install knox error. IndexError: list index out of range

New Contributor

ambari 2.7

HDP 3.1

enabled kerberos

used openldap

-----------------

After upgrading from HDP 2.7 to HDP 3.1, I manually uninstalled many services, such as spark2,hive,hbase and Knox, for some reason.

When I tried to install Knox, the installation failed.


stderr: /var/lib/ambari-agent/data/errors-15457.txt


Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/KNOX/package/scripts/knox_gateway.py", line 215, in <module>
    KnoxGateway().execute()
  File "/usr/lib/ambari-agent/lib/resource_management/libraries/script/script.py", line 352, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/KNOX/package/scripts/knox_gateway.py", line 52, in install
    import params
  File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/KNOX/package/scripts/params.py", line 27, in <module>
    from params_linux import *
  File "/var/lib/ambari-agent/cache/stacks/HDP/3.0/services/KNOX/package/scripts/params_linux.py", line 248, in <module>
    hbase_master_host = hbase_master_hosts[0]
IndexError: list index out of range


What caused this problem?

What should I do?


Thanks for helping me.