Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

llap port 10500 connection refused

Highlighted

llap port 10500 connection refused

New Contributor

hi all, we installed HDP 3.1 including autostart of hive server 2 and

hive interactive (llap).


I assume these services starts successfully, because


* I see two hive server processes running, using `ps x | grep java`

* netstat -punta gave me back the port number 10500 in state LISTEN

* the app master is in state running

* the 3 container are up and running

* the logs llap-daemon*.log, llap-daemon*.out does not have any error

log entries


When I connect the llap server directly on port 10500 via beeline, I can connect

without any error. After disconnect (ctrl+d) I execute `netstat -punta |

grep 10500`. The used port is in state TIME_AWAIT. Usually I would

expect to see this port two times, one `TIME_AWAIT` ond the another

`LISTEN`. But there is no additional entry.

(The non-llap hive server 2 on port 10000 behave like I expect.)


After some time the port is available again in state `LISTEN`. some

seconds later back to `TIME_AWAIT`. And then completely gone.


It feels like there is a `max connection allowed` property set

somewhere.


Any ideas or comments?

Do you need any log files?


1 REPLY 1

Re: llap port 10500 connection refused

New Contributor

Hi,

I just found the answer. The directory `hive.jar.directory` had the wrong permissions. the dir was owned by hdfs and only this user had the permission to write into. so after changing the permission bits to `777`, the llap startup works.