Support Questions
Find answers, ask questions, and share your expertise

Re: nifi disabled controller-services and ConsumeJMS failed

What error are you getting now? Could you please post

Also, it appears form your configuration that your queue name is 'Q1' but in NiFi config you're using 'queue://NiFiMQ' instead of 'queue://Q1'

I am not MQ administrator and there is nothing specific to NiFi anyone on the MQ side needs to do. Do you have a plain Java program that is able to send/receive messages from MQ instance you have created. That would be the easiest way to debug. The information such as queue, channel, queueManager, transportType and many other is provided by MQ administrators and have no relevance to NiFi.

Re: nifi disabled controller-services and ConsumeJMS failed

Ok, based on your additional info that was just posted you are having a connection issue to localhost:1419

Have you explicitly change it from the default port of 1414? I know you have a config window that shows some kind of listener on on 1419, but I am not sure what that is.

In any event, you're definitely having networking issue so, let's try this and see if you can connect to either 1419 and 1414 via telnet. From the terminal window execute the following:

> telnet localhost 1419

Repeat the same for 1414

Let me know

Re: nifi disabled controller-services and ConsumeJMS failed

Explorer

@ozhurakousky

Hi Oleg,

I had re-installed IBM MQ and setting up the queue manager, Channel, listener, and queue.

I will do more testing on Nifi and post the result. Thanks a lot

Andy

Re: nifi disabled controller-services and ConsumeJMS failed

Yes, you can see there are two properties in ConsumeJMS processor User Name and Password. So you can provide them there.

Re: nifi disabled controller-services and ConsumeJMS failed

Explorer

@ozhurakousky

Hi Oleg,

I finally got the connection between Nifi and IBM MQ working now. It's some configuration issue on MQ.

Thank you very much for your help and time. I am very appreciated.

Andy

Re: nifi disabled controller-services and ConsumeJMS failed

Andy, that is a great news!

If you don't mind, would you please post your working configuration here (masking user/password or course), so others can benefit from your experience.

Cheers

Oleg

View solution in original post

Re: nifi disabled controller-services and ConsumeJMS failed

Explorer

@ozhurakousky of course, I will post what I did on the IBM MQ here later today.

Re: nifi disabled controller-services and ConsumeJMS failed

Explorer

@ozhurakousky

Here is the steps to setup IBM MQ for the Nifi connection

1) Create queue manager myMQManager using MQ Explorer

2) create Channel and queue using the following commands

runmqsc myMQManager

def chl(myMQChannel) chltype(svrconn) replace

def chl(myMQChannel) chltype(clntconn) conname('localhost(1420)') QMNAME('myMQManager') replace

def ql(myMQqueue)

2) Grant necessary authorization for a user using MQ Explorer

2.1 Queue Manager Authorities Setting

right click your queue manager-->Object Authorities-->Add Role Based Authorities -->give the user access permission

2.2 Queue Authorities Setting

right click your queue-->Object Authorities-->Manage Authority Records-->Specific Profiles--> your queue--> Accumulated authorities-->setup your user Access Permission for the queue

3) After the configuration and setup your Nifi ConsumeJMS processor, you should be able connect to IBM MQ