Support Questions
Find answers, ask questions, and share your expertise

nifi logs stoped

New Contributor
I have Nifi adminstered by HDF 3.4.1.1, running on a single node. The nifi-app.log has stopped updating
ls /var/log/nifi2
nifi-app_2019-07-07_10.0.log  nifi-app_2019-07-07_15.0.log  nifi-app_2019-07-07_20.0.log   nifi-setup.log            nifi-user_2019-06-20.log  nifi-user_2019-06-28.log
nifi-app_2019-07-07_11.0.log  nifi-app_2019-07-07_16.0.log  nifi-app_2019-07-07_21.0.log   nifi-user_2019-06-07.log  nifi-user_2019-06-24.log  nifi-user_2019-07-03.log
nifi-app_2019-07-07_12.0.log  nifi-app_2019-07-07_17.0.log  nifi-app.log                   nifi-user_2019-06-10.log  nifi-user_2019-06-25.log  nifi-user_2019-07-04.log
nifi-app_2019-07-07_13.0.log  nifi-app_2019-07-07_18.0.log  nifi-bootstrap_2019-06-27.log  nifi-user_2019-06-11.log  nifi-user_2019-06-26.log  nifi-user_2019-07-05.log
nifi-app_2019-07-07_14.0.log  nifi-app_2019-07-07_19.0.log  nifi-bootstrap.log             nifi-user_2019-06-19.log  nifi-user_2019-06-27.log  nifi-user.log

There are nifi flows actively running since 07-07. How can I get logs flowing again and debug this issue?

The last entry in the nifi-app.log is:

2019-07-07 22:59:59,544 WARN [Timer-Driven Process Thread-14] o.a.n.controller.tasks.ConnectableTask Administratively Yielding ListS3
2 REPLIES 2

New Contributor

Turns out the nifi-app.log ownership got changed. After changing back to the nifi user I solved the issue.

Super Mentor

@pbendevis 
By default NiFi runs as user "nifi", based on the run.as= property inside the bootstrap.conf file .
Or by any chance if the NiFi log directory is customized like instead of default "/var/log/nifi" if we try to create the custom log directory like "/var/log/nifi2" then we will need to set the permission on that directory manually to make sure that the user who is going to run the NiFi process has proper write access to this directory.


The "nifi-app.log" log file permission can get changed if by mistake we try to start the NiFi process using some other user. So do you remember if you tried to start NiFi manually by any change as a different user?

 

; ;