Support Questions
Find answers, ask questions, and share your expertise

node registration failing

Master Collaborator

hadoop5.txthadoop3.txthadoop4.txthadoop2.txtI am reinstalling the cluster but I think iam doing something basic wrong , all node registration are failing with varying errors.

one step I am not sure is do I have to place HDP*.repo and HDP-UTILS*.repo in the /etc/yum.repos.d folder or does Ambari installation does it ?

also what do I have to do with this folder on the worker nodes ?

I am attaching the errorlogs for the nodes if you can please advise whats the issue iam facing.

3 REPLIES 3

@Sami Ahmad

The error seems to be an issue with fetching the HDP repos, please check the repos and run below command from CLI.

yum clean all
yum -d 0 -e 0 -v install hadoop_2_5_3_0_37-yarn

If that package got installed then check proxy server while fetching repos. If this helps accept the answer.

Master Collaborator

tried but its not going through. do I have to setup proxy for ambari on each node ? or proxy for some other component on hadoop2 , hadoop3, hadoop4 , hadoop 5?

[root@hadoop2 ~]# yum clean all
Loaded plugins: fastestmirror, refresh-packagekit, security
Cleaning repos: HDP-2.5 HDP-2.5.0.0 HDP-2.5.0.0-1245 HDP-UTILS-1.1.0.21 HDP-UTILS-2.5.0.0 HDP-UTILS-2.5.0.0-1245 Updates-ambari-2.4.3.0 base
              : centos-sclo-rh epel extras updates
Cleaning up Everything
Cleaning up list of fastest mirrors
You have new mail in /var/spool/mail/root
[root@hadoop2 ~]# yum -d 0 -e 0 -v install hadoop_2_5_3_0_37-yarn
Loading "fastestmirror" plugin
Loading "refresh-packagekit" plugin
Loading "security" plugin
Config time: 0.010
Yum Version: 3.2.29
rpmdb time: 0.000
Setting up Install Process
Setting up Package Sacks
Determining fastest mirrors
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=6&arch=x86_64&repo=os&infra=stock error was
14: PYCURL ERROR 22 - "The requested URL returned error: 504 Gateway Timeout"
Error: Cannot find a valid baseurl for repo: base
[root@hadoop2 ~]# ls /etc/yum.repos.d
ambari.repo       CentOS-Debuginfo.repo  CentOS-Media.repo        CentOS-Vault.repo  epel-testing.repo      HDP-2.5.0.0.repo  HDP-UTILS.repo
CentOS-Base.repo  CentOS-fasttrack.repo  CentOS-SCLo-scl-rh.repo  epel.repo          HDP-2.5.0.0-1245.repo  HDP.repo
[root@hadoop2 ~]#





Super Mentor

@Sami Ahmad

You are getting:

14: PYCURL ERROR 22 - "The requested URL returned error: 504 Gateway Timeout"

So suspecting that this might be a proxy issue.

Can you please check your "/etc/yum.conf" file and check if you have defined any proxy there? Also check if you are supposed to use that proxy or removing it works?

I see a similar thread here of yours with the same error which was resolved"

https://community.hortonworks.com/questions/107325/installing-ambari-with-local-repository-and-no-in...

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.