Support Questions
Find answers, ask questions, and share your expertise

oozie client installation failed

Explorer

Dear Community

 

I try to install hadoop cluster using ambari server. I did not install oozie from the beginning , the nodes have been installed and now I am trying to install clients.

Server install fails ..

Oozie client fails 

stderr: /var/lib/ambari-agent/data/errors-618.txt

Python script has been killed due to timeout after waiting 1800 secs
stdout: /var/lib/ambari-agent/data/output-618.txt

2019-11-18 11:29:14,797 - Stack Feature Version Info: Cluster Stack=3.1, Command Stack=None, Command Version=3.1.4.0-315 -> 3.1.4.0-315
2019-11-18 11:29:14,802 - Using hadoop conf dir: /usr/hdp/3.1.4.0-315/hadoop/conf
2019-11-18 11:29:14,804 - Group['hdfs'] {}
2019-11-18 11:29:14,805 - Group['hadoop'] {}
2019-11-18 11:29:14,805 - Group['users'] {}
2019-11-18 11:29:14,805 - User['yarn-ats'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop'], 'uid': None}
2019-11-18 11:29:14,806 - User['zookeeper'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop'], 'uid': None}
2019-11-18 11:29:14,807 - User['ams'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop'], 'uid': None}
2019-11-18 11:29:14,807 - User['oozie'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop', 'users'], 'uid': None}
2019-11-18 11:29:14,808 - User['ambari-qa'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop', 'users'], 'uid': None}
2019-11-18 11:29:14,808 - User['hdfs'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hdfs', 'hadoop'], 'uid': None}
2019-11-18 11:29:14,809 - User['yarn'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop'], 'uid': None}
2019-11-18 11:29:14,810 - User['mapred'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': ['hadoop'], 'uid': None}
2019-11-18 11:29:14,810 - File['/var/lib/ambari-agent/tmp/changeUid.sh'] {'content': StaticFile('changeToSecureUid.sh'), 'mode': 0555}
2019-11-18 11:29:14,811 - Execute['/var/lib/ambari-agent/tmp/changeUid.sh ambari-qa /tmp/hadoop-ambari-qa,/tmp/hsperfdata_ambari-qa,/home/ambari-qa,/tmp/ambari-qa,/tmp/sqoop-ambari-qa 0'] {'not_if': '(test $(id -u ambari-qa) -gt 1000) || (false)'}
2019-11-18 11:29:14,816 - Skipping Execute['/var/lib/ambari-agent/tmp/changeUid.sh ambari-qa /tmp/hadoop-ambari-qa,/tmp/hsperfdata_ambari-qa,/home/ambari-qa,/tmp/ambari-qa,/tmp/sqoop-ambari-qa 0'] due to not_if
2019-11-18 11:29:14,817 - Group['hdfs'] {}
2019-11-18 11:29:14,817 - User['hdfs'] {'fetch_nonlocal_groups': True, 'groups': ['hdfs', 'hadoop', u'hdfs']}
2019-11-18 11:29:14,818 - FS Type: HDFS
2019-11-18 11:29:14,818 - Directory['/etc/hadoop'] {'mode': 0755}
2019-11-18 11:29:14,831 - File['/usr/hdp/3.1.4.0-315/hadoop/conf/hadoop-env.sh'] {'content': InlineTemplate(...), 'owner': 'hdfs', 'group': 'hadoop'}
2019-11-18 11:29:14,831 - Directory['/var/lib/ambari-agent/tmp/hadoop_java_io_tmpdir'] {'owner': 'hdfs', 'group': 'hadoop', 'mode': 01777}
2019-11-18 11:29:14,846 - Repository['HDP-3.1-repo-2'] {'base_url': 'http://public-repo-1.hortonworks.com/HDP/centos7/3.x/updates/3.1.4.0', 'action': ['prepare'], 'components': [u'HDP', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'ambari-hdp-2', 'mirror_list': None}
2019-11-18 11:29:14,852 - Repository['HDP-3.1-GPL-repo-2'] {'base_url': 'http://public-repo-1.hortonworks.com/HDP-GPL/centos7/3.x/updates/3.1.4.0', 'action': ['prepare'], 'components': [u'HDP-GPL', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'ambari-hdp-2', 'mirror_list': None}
2019-11-18 11:29:14,854 - Repository['HDP-UTILS-1.1.0.22-repo-2'] {'base_url': 'http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.22/repos/centos7', 'action': ['prepare'], 'components': [u'HDP-UTILS', 'main'], 'repo_template': '[{{repo_id}}]\nname={{repo_id}}\n{% if mirror_list %}mirrorlist={{mirror_list}}{% else %}baseurl={{base_url}}{% endif %}\n\npath=/\nenabled=1\ngpgcheck=0', 'repo_file_name': 'ambari-hdp-2', 'mirror_list': None}
2019-11-18 11:29:14,855 - Repository[None] {'action': ['create']}
2019-11-18 11:29:14,856 - File['/tmp/tmpXTNL1e'] {'content': '[HDP-3.1-repo-2]\nname=HDP-3.1-repo-2\nbaseurl=http://public-repo-1.hortonworks.com/HDP/centos7/3.x/updates/3.1.4.0\n\npath=/\nenabled=1\ngpgcheck=...'}
2019-11-18 11:29:14,857 - Writing File['/tmp/tmpXTNL1e'] because contents don't match
2019-11-18 11:29:14,857 - File['/tmp/tmpuFs8Qh'] {'content': StaticFile('/etc/yum.repos.d/ambari-hdp-2.repo')}
2019-11-18 11:29:14,857 - Writing File['/tmp/tmpuFs8Qh'] because contents don't match
2019-11-18 11:29:14,858 - Package['unzip'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2019-11-18 11:29:14,938 - Skipping installation of existing package unzip
2019-11-18 11:29:14,938 - Package['curl'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2019-11-18 11:29:14,947 - Skipping installation of existing package curl
2019-11-18 11:29:14,947 - Package['hdp-select'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2019-11-18 11:29:14,955 - Skipping installation of existing package hdp-select
2019-11-18 11:29:14,959 - The repository with version 3.1.4.0-315 for this command has been marked as resolved. It will be used to report the version of the component which was installed
2019-11-18 11:29:15,158 - Package['zip'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2019-11-18 11:29:15,231 - Skipping installation of existing package zip
2019-11-18 11:29:15,233 - Package['oozie_3_1_4_0_315'] {'retry_on_repo_unavailability': False, 'retry_count': 5}
2019-11-18 11:29:15,241 - Installing package oozie_3_1_4_0_315 ('/usr/bin/yum -y install oozie_3_1_4_0_315')

Command failed after 1 tries

 

Any idea please?

 

Thanks

Asma

1 REPLY 1

Re: oozie client installation failed

Super Mentor

@asmarz 

Can you please try to run the same command from the failing Host to verify if there is any Yum (network) level issue?

# yum info oozie
# /usr/bin/yum -y install oozie_3_1_4_0_315

.

If you still face any issue then please share the following details from the failing node:

# yum whatprovides oozie
# grep -i 'proxy' /etc/yum.conf
# tail -20 /var/log/yum.log
(OR)
# grep 'oozie' /var/log/yum.log

.