Support Questions
Find answers, ask questions, and share your expertise

oozie email action error : EM007: Encountered an error while sending the email message over SMTP.

i am trying to trigger email to notify the workflow job status.

below is my workflow email action:

<action name="an-email">
<email xmlns="uri:oozie:email-action:0.1">
<to>abc@gmail.com</to>
<subject>Email notifications for ${wf:id()}</subject>
<body>The wf ${wf:id()} successfully completed.</body>
</email>
<ok to="end"/>
<error to="kill_job"/>
</action>
<kill name = "kill_job">
<message>Job failed</message>
</kill>
<end name = "end" />

below is the added properties in "oozie-site.xml" file

<property>  

<name>oozie.db.schema.name</name>  

<value>oozie</value> 

 </property>  

<property>  

<name>oozie.email.from.address</name>  

<value>oozie@gmail.com</value>  

</property> 

<property>  

<name>oozie.email.smtp.auth</name>  

<value>false</value>  

</property> 

 <property>  

<name>oozie.email.smtp.host</name> 

 <value>smtp.gmail.com</value>  

</property>  

<property> 

 <name>oozie.email.smtp.password</name>  

<value></value>  

</property>  

<property>
  <name>oozie.email.smtp.username</name>
  <value></value>
  </property>


<property>  

<name>oozie.email.smtp.port</name>  

<value>25</value>

while running above workflow am getting the error:

EM007: Encountered an error while sending the email message over SMTP.

if am missing anyting please let me know.

help me to resolve this issue.

Thanks in advance



0 REPLIES 0