Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

problem at confirm hosts

Solved Go to solution

problem at confirm hosts

New Contributor

I am trying to install a 5node cluster using ambari

Machine 1 : Master Node + Local repository + Ambari Server

Machine 2: Name node

Machine 3,4 & 5 : SlaveNode

Local repository is on the same system as master node and ambari-server.

I am using ambari server 2.6.2 to install hdp 2.6.5

repolist command lists :

1) HDP-2.6.5

2) HDP-UTILS-1.1.0.22

3) Updates-ambari-2.6.5.0

I have generated public by logging in as root sudo su and i placed the public key in home directory of the slave node, even though i was able to do password less SSH between slave and master but I'm getting this error.

==========================
Creating target directory...
========================== Command start time 2018-07-17 17:01:51 Permission denied (publickey,password).
SSH command execution finished
host=aries-hdp-mnode.so.cccounty.us, exitcode=255
Command end time 2018-07-17 17:01:51

ERROR: Bootstrap of host aries-hdp-mnode.so.cccounty.us fails because previous action finished with non-zero exit code (255)
ERROR MESSAGE: Permission denied (publickey,password).

STDOUT:
Permission denied (publickey,password).

@Geoffrey Shelton Okot

@Vinicius Higa Murakami

ambari-error.pngserver-log.txt

Kindly Please help me out.

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: problem at confirm hosts

Super Mentor

@Deepak SANAGAPALLI

The error indicates that you have not properly configured P{asswordless SSH from ambari server host to "aries-hdp-mnode.so.cccounty.us" host.

ERROR:root:ERROR: Bootstrap of host aries-hdp-mnode.so.cccounty.us fails because previous action finished with non-zero exit code (255)
ERROR MESSAGE: Permission denied (publickey,password).^M

.

So please try this:

1. Please verify from ambari server host if you can do passwordless SSH to "aries-hdp-mnode.so.cccounty.us" host ? or not?

# ssh root@aries-hdp-mnode.so.cccounty.us

.

2. If the above command is asking for password means the passwordless ssh is not configured, Hence in this case please run the following command to push the SSH public key from ambari server host to the agent host.

# ssh-copy-id -i ~/.ssh/id_rsa.pub  root@aries-hdp-mnode.so.cccounty.us

3. Then retry the step 1 to see if password less ssh works.

4. Now retry from ambari UI to register this host.

Make sure that IPtables / firewall is disabled on these hosts. And the hostnmae is correctly being reflected when we run the following command on ambari server host or on ambari agent host ( it should show desired hostname)

# hostname -f

Side NOTE: You must make sure that all your cluster hostnames are in lowercasse else later when you will enable cluster on this cluster then you might face some issues..

3 REPLIES 3

Re: problem at confirm hosts

Super Mentor

@Deepak SANAGAPALLI

The error indicates that you have not properly configured P{asswordless SSH from ambari server host to "aries-hdp-mnode.so.cccounty.us" host.

ERROR:root:ERROR: Bootstrap of host aries-hdp-mnode.so.cccounty.us fails because previous action finished with non-zero exit code (255)
ERROR MESSAGE: Permission denied (publickey,password).^M

.

So please try this:

1. Please verify from ambari server host if you can do passwordless SSH to "aries-hdp-mnode.so.cccounty.us" host ? or not?

# ssh root@aries-hdp-mnode.so.cccounty.us

.

2. If the above command is asking for password means the passwordless ssh is not configured, Hence in this case please run the following command to push the SSH public key from ambari server host to the agent host.

# ssh-copy-id -i ~/.ssh/id_rsa.pub  root@aries-hdp-mnode.so.cccounty.us

3. Then retry the step 1 to see if password less ssh works.

4. Now retry from ambari UI to register this host.

Make sure that IPtables / firewall is disabled on these hosts. And the hostnmae is correctly being reflected when we run the following command on ambari server host or on ambari agent host ( it should show desired hostname)

# hostname -f

Side NOTE: You must make sure that all your cluster hostnames are in lowercasse else later when you will enable cluster on this cluster then you might face some issues..

Re: problem at confirm hosts

New Contributor

Hello, thank you for your response. Initially i did ssh root@hostname but i got error saying permission denied and later i followed the steps you given even though I'm getting another error saying permission denied. Here I attach the error please take a look. ambari-errorr.png @Jay Kumar SenSharma @Geoffrey Shelton Okot @Vinicius Higa Murakami

Re: problem at confirm hosts

New Contributor

Issue resolved: I had reset the password for root, it solved my issue.

Thanks