Support Questions
Find answers, ask questions, and share your expertise

python-xml is needed by ambari-server-2.4.1.0-0.x86_64

Explorer

i run yum install ambari-server in centos 7 and python 2.7,but there some erros like this:

python-xml is needed by ambari-server-2.4.1.0-0.x86_64

2 REPLIES 2

Re: python-xml is needed by ambari-server-2.4.1.0-0.x86_64

@Ye Jun

Looks like you have done multiple posting with same query.

I see that the following is mentioned as a dependency:

rpm.dependency.list.suse=postgresql-server >= 8.1,\nRequires: openssl,\nRequires: python-xml,\nRequires: python >= 2.6

https://github.com/apache/ambari/blob/release-2.4.1/ambari-server/src/main/package/dependencies.prop...

.

- Which OS are you using and the exact python version?

Re: python-xml is needed by ambari-server-2.4.1.0-0.x86_64

@Ye Jun

- As per the note: http://docs.hortonworks.com/HDPDocuments/Ambari-2.4.1.0/bk_ambari-installation/content/download_the_...

- When you install the Ambari Server, the PostgreSQL packages and dependencies must be available for install. These packages are typically available as part of your Operating System repositories. Please confirm you have the appropriate repositories available for the postgresql-server packages.

Similarly the openssl + python-xml dependencies also should come from the OS repository.