Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

resource_management.core.exceptions.Fail: Execution of 'conf-select set-conf-dir --package zookeeper --stack-version 2.4.0.0-169 --conf-version 0' returned 1. zookeeper not installed or incorrect package name

Solved Go to solution
Highlighted

resource_management.core.exceptions.Fail: Execution of 'conf-select set-conf-dir --package zookeeper --stack-version 2.4.0.0-169 --conf-version 0' returned 1. zookeeper not installed or incorrect package name

Contributor

When I install zookeeper use ambari-2.2.1.0,The ambari throws one exception,as fllowing

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/common-services/ZOOKEEPER/3.4.5.2.0/package/scripts/zookeeper_server.py", line 179, in <module>
    ZookeeperServer().execute()
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 219, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/common-services/ZOOKEEPER/3.4.5.2.0/package/scripts/zookeeper_server.py", line 70, in install
    self.configure(env)
  File "/var/lib/ambari-agent/cache/common-services/ZOOKEEPER/3.4.5.2.0/package/scripts/zookeeper_server.py", line 49, in configure
    zookeeper(type='server', upgrade_type=upgrade_type)
  File "/usr/lib/python2.6/site-packages/ambari_commons/os_family_impl.py", line 89, in thunk
    return fn(*args, **kwargs)
  File "/var/lib/ambari-agent/cache/common-services/ZOOKEEPER/3.4.5.2.0/package/scripts/zookeeper.py", line 40, in zookeeper
    conf_select.select(params.stack_name, "zookeeper", params.current_version)
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/conf_select.py", line 252, in select
    shell.checked_call(get_cmd("set-conf-dir", package, version), logoutput=False, quiet=False, sudo=True)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70, in inner
    result = function(command, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 92, in checked_call
    tries=tries, try_sleep=try_sleep)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 140, in _call_wrapper
    result = _call(command, **kwargs_copy)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call
    raise Fail(err_msg)
resource_management.core.exceptions.Fail: Execution of 'conf-select set-conf-dir --package zookeeper --stack-version 2.4.0.0-169 --conf-version 0' returned 1. zookeeper not installed or incorrect package name

some body can help me? thank.........s!

ps: I use

4608-qq图片20160529115631.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: resource_management.core.exceptions.Fail: Execution of 'conf-select set-conf-dir --package zookeeper --stack-version 2.4.0.0-169 --conf-version 0' returned 1. zookeeper not installed or incorrect package name

That conf-select call tries to create the following symlink.

/usr/hdp/current/zookeeper-server/conf -> /etc/zookeeper/2.4.0.0-169/0

1. Make sure zookeeper server is actually installed and Ambari shows it as a component for that host. rpm -qa | grep zookeeper_.*server

2. Set its symlink. hdp-select set zookeeper-server 2.4.0.0-169 # this will create symlink /usr/hdp/current/zookeeper-server -> /usr/hdp/2.4.0.0-169/zookeeper

3. Restart ZK Server on that host via the UI.

View solution in original post

4 REPLIES 4
Highlighted

Re: resource_management.core.exceptions.Fail: Execution of 'conf-select set-conf-dir --package zookeeper --stack-version 2.4.0.0-169 --conf-version 0' returned 1. zookeeper not installed or incorrect package name

Can you list the contents of folders "/usr/hdp" and "/usr/hdp/2.4.0.0-169"?

Also the output of "hdp-select | grep zookeeper" on the host where the command failed.

Highlighted

Re: resource_management.core.exceptions.Fail: Execution of 'conf-select set-conf-dir --package zookeeper --stack-version 2.4.0.0-169 --conf-version 0' returned 1. zookeeper not installed or incorrect package name

Contributor

4636-qq图片20160529134442.png

4637-qq图片20160529134448.png

guys, please help me

Highlighted

Re: resource_management.core.exceptions.Fail: Execution of 'conf-select set-conf-dir --package zookeeper --stack-version 2.4.0.0-169 --conf-version 0' returned 1. zookeeper not installed or incorrect package name

Contributor

and i found that

4638-qq图片20160529140034.png

Re: resource_management.core.exceptions.Fail: Execution of 'conf-select set-conf-dir --package zookeeper --stack-version 2.4.0.0-169 --conf-version 0' returned 1. zookeeper not installed or incorrect package name

That conf-select call tries to create the following symlink.

/usr/hdp/current/zookeeper-server/conf -> /etc/zookeeper/2.4.0.0-169/0

1. Make sure zookeeper server is actually installed and Ambari shows it as a component for that host. rpm -qa | grep zookeeper_.*server

2. Set its symlink. hdp-select set zookeeper-server 2.4.0.0-169 # this will create symlink /usr/hdp/current/zookeeper-server -> /usr/hdp/2.4.0.0-169/zookeeper

3. Restart ZK Server on that host via the UI.

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here