Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

resource_management.core.exceptions@zookeeper

Highlighted

resource_management.core.exceptions@zookeeper

New Contributor

I have been facing the below error on namenode while installing ambari on centos.

could you please help me to solve this error.

ZK is installed on datanodes but it is failing on Namenode.

 

The zookeeper is installed and the results below.

 

 

[root@ambari-server zookeeper]# yum list installed | grep zookeeper
zookeeper_2_6_1_0_129.noarch 3.4.6.2.6.1.0-129 installed
[root@ambari-server zookeeper]#

 

 

 

 

[root@ambari-server zookeeper]# yum list available | grep zookeeper
zookeeper.noarch 3.4.6.2.6.1.0-129 HDP-2.6-repo-1
zookeeper-server.noarch 3.4.6.2.6.1.0-129 HDP-2.6-repo-1
zookeeper_2_6_1_0_129-server.noarch 3.4.6.2.6.1.0-129 HDP-2.6-repo-1

2019-09-28 09:12:55,083 - The 'zookeeper-client' component did not advertise a version. This may indicate a problem with the component packaging. However, the stack-select tool was able to report a single version installed (2.6.1.0-129). This is the version that will be reported.
2019-09-28 09:13:11,462 - The 'zookeeper-client' component did not advertise a version. This may indicate a problem with the component packaging. However, the stack-select tool was able to report a single version installed (2.6.1.0-129). This is the version that will be reported.
Traceback (most recent call last):
File "/var/lib/ambari-agent/cache/common-services/ZOOKEEPER/3.4.5/package/scripts/zookeeper_client.py", line 79, in <module>
ZookeeperClient().execute()
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 375, in execute
method(env)
File "/var/lib/ambari-agent/cache/common-services/ZOOKEEPER/3.4.5/package/scripts/zookeeper_client.py", line 59, in install
self.install_packages(env)
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 811, in install_packages
name = self.format_package_name(package['name'])
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 546, in format_package_name
raise Fail("Cannot match package for regexp name {0}. Available packages: {1}".format(name, self.available_packages_in_repos))
resource_management.core.exceptions.Fail: Cannot match package for regexp name zookeeper_${stack_version}. Available packages:

 

Don't have an account?
Coming from Hortonworks? Activate your account here