Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

setpgid(2296, 0) failed - [Errno 13] Permission denied issue, server getting stopped after some time

Contributor

ambari-server start Using python /usr/bin/python2 Starting ambari-server Ambari Server running with administrator privileges. Organizing resource files at /var/lib/ambari-server/resources...

WARNING: setpgid(2296, 0) failed - [Errno 13] Permission denied Server PID at: /var/run/ambari-server/ambari-server.pid Server out at: /var/log/ambari-server/ambari-server.out Server log at: /var/log/ambari-server/ambari-server.log Waiting for server start....................

Ambari Server 'start' completed successfully.

But server getting stopped automatically.

I can refer to https://community.hortonworks.com/questions/10044/ambari-server-start-warning-setpgid4340-0-failed-e... but didn't make any sense on how to apply the patch.

Any help would be great....! Any clear steps to resolve the issue and apply patch.

Thanks

1 ACCEPTED SOLUTION

13 REPLIES 13

Mentor

Contributor

I did refer to that, But didn't get resolved.

@Vinod Nerella

WARNING: setpgid(2296, 0) failed - [Errno 13] Permission denied --> This does not look healthy

Whats your ambari version? OS?

https://issues.apache.org/jira/browse/AMBARI-14466

Patch is in the jira

Apply https://ariejan.net/2009/10/26/how-to-create-and-apply-a-patch-with-git/ or https://www.drupal.org/node/1399218

Contributor

Ambari version - v2.2.0.0

from repo file -> Updates-ambari-2.2.0.0

OS - CentOS Linux release 7.2.1511 (Core)

But in error log the issue shows as below.

10 Feb 2016 13:54:19,728 ERROR [main] DBAccessorImpl:102 - Error while creating database accessor org.postgresql.util.PSQLException: FATAL: no pg_hba.conf entry for host "127.0.0.1", user "ambari", database "ambari", SSL off

Contributor

@Neeraj Sabharwal Is this only way i.e.. by applying patch to rectify the bug or any other way to fix bug?

@Vinod Nerella You can remove ambari-server and resinstall...I had the same issue and I ended up doing this "couple of times"

otherwise, patch or http://docs.hortonworks.com/HDPDocuments/Ambari/Ambari-2.1.2.1/index.html

Contributor

@Neeraj Sabharwal I am also doing couple of times. But couldn't get resolved till now.

Thanks for the reply.

But I tried Ambari 2.1.2.1, I got the issue as follows.

https://community.hortonworks.com/questions/15495/amabari-server-212-setup-error-while-creating-data...

Can you help with this error?

Thanks in advance!

Have a nice day!

@Vinod Nerella I did see that thread. Please do me a favor by installing mysql or use postgres option.

I wanted to comment this on that thread but I chose not to confuse things.

Guru

Hi Vinod,

You can use following steps to apply patch on your server.

1. Download patch to local or server.

2. You can use below command to apply it under ambari home dir.

$ patch -p0 -i /path/to/AMBARI-14466.patch

Contributor

@Neeraj Sabharwal Thanks Neeraj for helping this out. It worked for me too.

But ambari showing started but yet its getting stopped for me because of the following issue in log files.

DBAccessorImpl:102 - Error while creating database accessor org.postgresql.util.PSQLException: FATAL: no pg_hba.conf entry for host "127.0.0.1", user "ambari", database "ambari", SSL off

Could you help on this issue also please?

@Vinod Nerella Its different issue. Its related to postgres. See this