Support Questions
Find answers, ask questions, and share your expertise

setting phoenix.schema.isNamespaceMappingEnabled in squirrel

setting phoenix.schema.isNamespaceMappingEnabled in squirrel

I am using squirrel to connect to phoenix. I have enabled the property phoenix.schema.isNamespaceMappingEnabled on the server side. But how do i enable it at the client side when connecting from squirrel. Any thoughts?

I tried adding the hbase-site.xml in the extra classpath and restarted squirrel too. it still doesnt work

6 REPLIES 6

Re: setting phoenix.schema.isNamespaceMappingEnabled in squirrel

Super Collaborator

You need to add HBASE_CONF dir to the classpath, but not hbase-site.xml.

Re: setting phoenix.schema.isNamespaceMappingEnabled in squirrel

@ssoldatov, i am using windows and i have my hbase-site.xml in the path D:\HBASE_CONF_DIR and have hbase-sit.xml in this path. I added this in the classpath. but still it doesnt work

Re: setting phoenix.schema.isNamespaceMappingEnabled in squirrel

Super Collaborator

@ARUN that's definitely strange. I've added hbase conf dir in 'Extra Class Path' tab, reconnected squirrel (I'm using 3.7) and everything works just fine after that. Please check that hbase-site.xml that located in D:\HBASE_CONF_DIR has

<property>
<name>phoenix.schema.isNamespaceMappingEnabled</name> 
<value>true</value> 
</property> 

Also you may check that the directory is really in the classpath. Since squirrel is looking for driver class in the classpath, it reports about directories:

For driver '<your driver name>', the JVM says the file is a directory: <path to hbase conf dir>

Re: setting phoenix.schema.isNamespaceMappingEnabled in squirrel

Expert Contributor

don't add the hbase-site.xml, just add the folder where hbase-site.xml is , if hbase is at /home/phoenix/hbase-site.xml, then just add /home/phoenix/ to the class path. see if that works.

Re: setting phoenix.schema.isNamespaceMappingEnabled in squirrel

one more thing i am using Zeppelin too to do the same. still getting the same exception. Any clues, i ahve attached the zeppelin screenshotzeppelin-phoenix.png

Re: setting phoenix.schema.isNamespaceMappingEnabled in squirrel

Contributor

This works if you specify the properties inside of the classpath.

13591-screen-shot-2017-03-13-at-104038-am.png

You can then select the schema within the aliases.

13592-screen-shot-2017-03-13-at-103908-am.png