Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

snappy issue

Highlighted

snappy issue

I am upgrading HDP to 2.6.5 , but when i install hdp then in one of the node it is getting failed showing the snappy issue however for other nodes it wet well.

result of rpm -qa | grep snappy on all the nodes are same but I do not understand why is it getting fail in one of node (ambari -serever node .

snappy-1.0.5-1.el6.x86_64

snappy-devel-1.0.5-1.el6.x86_64

esolving Dependencies
--> Running transaction check
---> Package snappy.x86_64 0:1.0.5-1.el6 will be updated
--> Processing Dependency: snappy(x86-64) = 1.0.5-1.el6 for package: snappy-devel-1.0.5-1.el6.x86_64
---> Package snappy.x86_64 0:1.1.0-3.el7 will be an update
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies
Error: Package: snappy-devel-1.0.5-1.el6.x86_64 (@HDP-UTILS-1.1.0.21)
           Requires: snappy(x86-64) = 1.0.5-1.el6
           Removing: snappy-1.0.5-1.el6.x86_64 (@HDP-UTILS-1.1.0.21)
               snappy(x86-64) = 1.0.5-1.el6
           Updated By: snappy-1.1.0-3.el7.x86_64 (rhel-7-server-rpms)
               snappy(x86-64) = 1.1.0-3.el7
2 REPLIES 2

Re: snappy issue

Super Mentor

@Anurag Mishra

One strange thing i am noticing that the old packages are "el6" and the new packages which is going to be updated has "el7".

So are you sure that you have the exactly same repo configured on ambari server host as well which is there on other hosts?

# rpm -qa | grep snappy
# yum --showduplicates list snappy
# rpm -ql snappy-devel
# yum -v repolist

.

And can you please share the output of the above commands here from AmbariServer host and also please compare this output from other cluster nodes.

By any chance do you see a difference in the Operating System version on AmbariServer host and on other cluster nodes?

# cat /etc/redhat-release

.

Re: snappy issue

Super Mentor

@Anurag Mishra

In order to resolve such issue please refer to the doc: "Problem: DataNode Fails to Install on RHEL/CentOS 7"

Hadoop requires the snappy-devel package that is a lower version that what is on the machine already.  Run the following on the host and retry.
.
# yum remove snappy
# yum install snappy-devel

.