Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 02-28-2022 02:04 AM
Solr process keeps stopping each 3 days
I am getting the below error
22/02/27 05:15:21 ERROR handler.RequestHandlerBase: [qtp417301556-3371]: org.apache.solr.common.SolrException: Exception writing document id 6ae68838-4669-4f11-9544-53d22025085c-5 to the index; possible analysis error: number of documents in the index cannot exceed 2147483519
Caused by: java.lang.IllegalArgumentException: number of documents in the index cannot exceed 2147483519
I have 1 solar server, Cloudera version 7.4.4, solar version 8.4.1
what do you suggest to solve the problem?
Thanks
Created 03-07-2022 11:46 PM
Hello @Almolki
Thanks for using Cloudera Community. Based on the Post, Your Team is experiencing [1] on Solr 8.4.1.
The Issue being faced by your Team is a Known Limitation of Solr, wherein each Shard can host 2B Documents Maximum [2]. Your Team have following Choices:
Kindly review & let us know if your Queries have been addressed.
Regards, Smarak
[1] Caused by: java.lang.IllegalArgumentException: number of documents in the index cannot exceed 2147483519
[2] https://issues.apache.org/jira/browse/SOLR-3504
[3] https://solr.apache.org/guide/8_4/shard-management.html#shard-management
Created 03-07-2022 11:21 PM
any help?
Created 03-07-2022 11:46 PM
Hello @Almolki
Thanks for using Cloudera Community. Based on the Post, Your Team is experiencing [1] on Solr 8.4.1.
The Issue being faced by your Team is a Known Limitation of Solr, wherein each Shard can host 2B Documents Maximum [2]. Your Team have following Choices:
Kindly review & let us know if your Queries have been addressed.
Regards, Smarak
[1] Caused by: java.lang.IllegalArgumentException: number of documents in the index cannot exceed 2147483519
[2] https://issues.apache.org/jira/browse/SOLR-3504
[3] https://solr.apache.org/guide/8_4/shard-management.html#shard-management
Created 03-22-2022 06:27 AM