Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

sqoop import of tables with space in table name

Solved Go to solution
Highlighted

sqoop import of tables with space in table name

Explorer

Sqoop import fails while importing tables that has space and special characters in the table name.

 

 

command used:

sqoop import --connect <>  --username <> --password <> --table "employee details information" --as-parquetfile --delete-target-dir --target-dir  /hdfs/dir/ --m 1 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: sqoop import of tables with space in table name

Explorer

using the query option helped.

 

solution :

sqoop import  --connect <>  --username <> -password <> --as-parquetfile --delete-target-dir --target-dir /hdfs/dir/  --query "select * from [DB_SCHEMA_NAME].[table_name] where \$CONDITIONS;" --m 1

1 REPLY 1

Re: sqoop import of tables with space in table name

Explorer

using the query option helped.

 

solution :

sqoop import  --connect <>  --username <> -password <> --as-parquetfile --delete-target-dir --target-dir /hdfs/dir/  --query "select * from [DB_SCHEMA_NAME].[table_name] where \$CONDITIONS;" --m 1

Don't have an account?
Coming from Hortonworks? Activate your account here