Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

starting up a ambari on a newly deployed cluster

starting up a ambari on a newly deployed cluster

New Contributor

the ambari setup was done successfully and after rebooting the machine that housed the ambari server im getting the following error while firing the 'ambari-server start'

ambari-server start
Using python /usr/bin/python
Starting ambari-server
Ambari Server running with administrator privileges.
Organizing resource files at /var/lib/ambari-server/resources...
Ambari database consistency check started...
Server PID at: /var/run/ambari-server/ambari-server.pid
Server out at: /var/log/ambari-server/ambari-server.out
Server log at: /var/log/ambari-server/ambari-server.log
Waiting for server start.........Unable to determine server PID. Retrying...
......Unable to determine server PID. Retrying...
......Unable to determine server PID. Retrying...
ERROR: Exiting with exit code -1.
REASON: Ambari Server java process died with exitcode 255. Check /var/log/ambari-server/ambari-server.out for more information.

cat /var/log/ambari-server/ambari-server.out
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=128m; support was removed in 8.0
An unexpected error occured during starting Ambari Server.
java.util.NoSuchElementException
at java.util.Scanner.throwFor(Scanner.java:862)
at java.util.Scanner.next(Scanner.java:1371)
at org.apache.ambari.server.checks.DatabaseConsistencyCheckHelper.checkDBVersionCompatible(DatabaseConsistencyCheckHelper.java:222)
at org.apache.ambari.server.controller.AmbariServer.main(AmbariServer.java:1010)

edit:using maria db as datbase fro ambari server and maria was already started and is running fine ,but ambari-server start is failing ith above error

11 REPLIES 11

Re: starting up a ambari on a newly deployed cluster

Super Mentor

@Gopi krishna

All the version of MariaDB are not supported with Ambari.

So please let us know your AmbariServer Version and also the MariaDB version.

For Ambari 2.5.2 Support metrics is here: (Maria DB 10.1) https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.1/bk_support-matrices/content/ch_matrices-amb...

AND

https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.2/bk_support-matrices/content/ch_matrices-amb...

Re: starting up a ambari on a newly deployed cluster

New Contributor

is the above issue because of the database?

Re: starting up a ambari on a newly deployed cluster

New Contributor

fyi

[root@master6 common-services]# rpm -qa|grep ambari-server
ambari-server-2.5.2.0-298.x86_64
[root@master6 common-services]# rpm -qa |grep maria
mariadb-5.5.56-2.el7.x86_64
mariadb-devel-5.5.56-2.el7.x86_64
mariadb-libs-5.5.56-2.el7.x86_64
mariadb-server-5.5.56-2.el7.x86_64

Re: starting up a ambari on a newly deployed cluster

Super Mentor

@Gopi krishna

Yes i am suspecting that this issue is related to Database Compatibility Version. As the error stackTrace shows that the server start is failing at the "checkDBVersionCompatible"

java.util.NoSuchElementException
 at java.util.Scanner.throwFor(Scanner.java:862)
 at java.util.Scanner.next(Scanner.java:1371)
 at 
org.apache.ambari.server.checks.DatabaseConsistencyCheckHelper.checkDBVersionCompatible(DatabaseConsistencyCheckHelper.java:222)

.

Re: starting up a ambari on a newly deployed cluster

Super Mentor

@Gopi krishna

Is there any specific reason that you want to use Maria DB (instead of MySQL)?

If you want to use Maria DB then please try with 10.1 version.

Re: starting up a ambari on a newly deployed cluster

New Contributor

already configured a 4 node cluster with many of the services,cant afford to shut down db/re create a new db. Is it possible to start ambari-server with a ignore option

Re: starting up a ambari on a newly deployed cluster

Super Mentor

@Gopi krishna

With incompatible version you might find issues later as well.

But for a quick check try the following to see if it helps starting the server, Else try changing the DB version.

# ambari-server start --skip-database-check

.

Re: starting up a ambari on a newly deployed cluster

Super Mentor

@Gopi krishna

Also please check if the following file exist ? (if not then please create one)

# cat /var/lib/ambari-server/resources/version
2.5.2.0

# ls -lart /var/lib/ambari-server/resources/version
-rwxr-xr-x. 1 root root 8 Aug 30 07:22 /var/lib/ambari-server/resources/version

.

Looks like you have that missing file. Thats why it is causing this issue.

As per the code: https://github.com/apache/ambari/blob/release-2.5.2/ambari-server/src/main/java/org/apache/ambari/se...

Ambari will need to read ambari server version from that file during startup.

So please create a file "/var/lib/ambari-server/resources/version" and add the version as 2.5.2.0 inside that file then try restarting ambari server . It should come up fine.

Re: starting up a ambari on a newly deployed cluster

New Contributor

i did tghe following changes but still no luck

[root@master6 common-services]# mv /var/lib/ambari-server/resources/version /var/lib/ambari-server/resources/version_bkup
[root@master6 common-services]#
[root@master6 common-services]#
[root@master6 common-services]# vi /var/lib/ambari-server/resources/version
[root@master6 common-services]# cat /var/lib/ambari-server/resources/version
2.5.2.0
[root@master6 common-services]# ambari-server start
Using python /usr/bin/python
Starting ambari-server
Ambari Server running with administrator privileges.
Organizing resource files at /var/lib/ambari-server/resources...
Ambari database consistency check started...
Server PID at: /var/run/ambari-server/ambari-server.pid
Server out at: /var/log/ambari-server/ambari-server.out
Server log at: /var/log/ambari-server/ambari-server.log
Waiting for server start...........ERROR: Exiting with exit code -1.
REASON: Ambari Server java process has stopped. Please check the logs for more information.

Don't have an account?
Coming from Hortonworks? Activate your account here