Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

syslog messages : automount| key "hadoop-site.xml" not found in map source(s).

syslog messages : automount| key "hadoop-site.xml" not found in map source(s).

New Contributor

Hello,

 

The messages below appear every couple of minutes in the syslog:

DAEMON|ERR|automount| lookup_mount: exports lookup failed for META-INF
|DAEMON|CRIT|automount| key "META-INF" not found in map source(s).
|DAEMON|CRIT|automount| key "hadoop-site.xml" not found in map source(s).
|DAEMON|ERR|automount| create_client: hostname lookup failed: Name or service not known
|DAEMON|ERR|automount| create_client: hostname lookup failed: Name or service not known
DAEMON|ERR|automount| lookup_mount: exports lookup failed for hadoop-site.xml

Does any one know where this comes from?

 

Regards Hans-Peter

1 REPLY 1

Re: syslog messages : automount| key "hadoop-site.xml" not found in map source(s).

Master Collaborator

I would start by having a look in the following files to see if somehow somebody placed some reference to a "hadoop-site.xml" file and a META-INF mount point:

 

/etc/fstab

/etc/auto.*   (there will be 3 auto.something files in /etc, I think...look in each)

 

Are you using automount to handle your NFS mounts on this system?  If not,  you can just disable automount/autofs and that should clear this up.  Something is misconfigured with regard to your autmounted filesystems, that's the gist of it.