Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

transparent_hugepage Disable warning in Ambari installation

Solved Go to solution
Highlighted

transparent_hugepage Disable warning in Ambari installation

Rising Star

Hi i want to install Amari 2.4 in Ubuntu 14.2 on EC2 . i got warning msge that transparent_hugepage is enable ..so did below steps

sudo vi /etc/default/grub

add the below

GRUB_CMDLINE_LINUX_DEFAULT=”transparent_hugepage=never”

sudo update-grub

sudo reboot

cat /sys/kernel/mm/transparent_hugepage/enabled

always madvise [never]

but no luck i got same error masge..please help me out of this warning

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: transparent_hugepage Disable warning in Ambari installation

Super Mentor

@rama

Have you explored the following option:

1. installing the sysfsutils package:

  sudo apt install sysfsutils

2. Then append a line with that setting to /etc/sysfs.conf:

  kernel/mm/transparent_hugepage/enabled = never

.

Also please check the following as well:

cat /sys/kernel/mm/transparent_hugepage/enabled 
  #  always madvise [never]
cat /sys/kernel/mm/transparent_hugepage/defrag
  #  [always] madvise never
cat  /proc/cmdline
  # initrd=\initramfs-linux.img root=/dev/sda2    rw splash transparent_hugepage=never

.

View solution in original post

2 REPLIES 2
Highlighted

Re: transparent_hugepage Disable warning in Ambari installation

Super Mentor

@rama

Have you explored the following option:

1. installing the sysfsutils package:

  sudo apt install sysfsutils

2. Then append a line with that setting to /etc/sysfs.conf:

  kernel/mm/transparent_hugepage/enabled = never

.

Also please check the following as well:

cat /sys/kernel/mm/transparent_hugepage/enabled 
  #  always madvise [never]
cat /sys/kernel/mm/transparent_hugepage/defrag
  #  [always] madvise never
cat  /proc/cmdline
  # initrd=\initramfs-linux.img root=/dev/sda2    rw splash transparent_hugepage=never

.

View solution in original post

Re: transparent_hugepage Disable warning in Ambari installation

Rising Star

@Jay SenSharma

Thanks its working fine warning masg are not coming ..

Don't have an account?
Coming from Hortonworks? Activate your account here