Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

unable to access HDFS UI after kerberos

unable to access HDFS UI after kerberos

New Contributor

I have enabled kerberos in my cluster. I am unable to access my HDFS or all UI, its required authentication. I have tried spnego for this. Still my issue is persist. Could any please provide me the steps for this issue. How to access my UI even my cluster is in kerberosized?

6 REPLIES 6

Re: unable to access HDFS UI after kerberos

Mentor

@Mohamed Farook


There is post install steps that you should perform. Configuring HTTP Authentication for HDFS, YARN, MapReduce2, HBase, Oozie, Falcon and Storm

You should be able to access the UI's after this

Re: unable to access HDFS UI after kerberos

New Contributor

Hi Shelton,

I have tried this link after enabled Kerberos cluster. Still it's not working.

I have tried to install MIT in my windows machine, but when I am clicking on get tickets it's prompting for principal and password. I am not sure on this well.

If I enabled my cluster as kerberos and trying to access the HDFS webpage and prompting for authentication. What could be the username and password?

Regards,

Mohamed farook

Re: unable to access HDFS UI after kerberos

New Contributor

Any updates pls ?

Highlighted

Re: unable to access HDFS UI after kerberos

New Contributor

Hi Mohamed, have you tried using your LDAP/ active directory login as username and password (this s how your kerberos is setup?).

Re: unable to access HDFS UI after kerberos

New Contributor

Hi Chetna,

Actually I have not configured any LDAP/AD in my cluster. If you dont mind can u share the links or docs for LDAP setup.

If you tried any docs for this issue. Can you please provide me.

Regards,

MF

Re: unable to access HDFS UI after kerberos

Mentor

@Mohamed Farook

Can you give me a screenshot your MIT UI on windows? Have you tried the root/admin@REALM plus its password?

For the AD integration, you will need to get the credentials and specific config et LDAP(S) URL which is site-specific from you AD Admin these are the major steps

Set the correct parameters

# ambari-server setup-ldap 

Restart so Ambari picks up the new changes

# ambari-server restart 

Restart the agents

# ambari-agent restart 

The below will synchronize all the valid users in your LDAP with your cluster which might not be what you want !!!

# ambari-server sync-ldap --all

You can synchronize a particular group and users, and also to understand the tasks to undertake please read the latest HDP 2.6 doc

Configuring Ambari Authentication with LDAP or AD

Hope that helps