Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Please see the Cloudera blog for information on the Cloudera Response to CVE-2021-4428

unable to install cloudera manager

New Contributor

Hi Team,

 

I have recently installed cloudera manager on the hadoop environment. I have installed and when i try to run the 

service cloudera-scm-agent restart
service cloudera-scm-server restart after changes in  vi /etc/cloudera-scm-agent/config.ini.

I am getting the error .. Installation failed.

But when i try to debug the log files, i could see this:

[29/Apr/2020 13:10:09 +0000] 21400 MonitorDaemon-Scheduler __init__ INFO Monitor ready to report: ('HostMonitor',)
[29/Apr/2020 13:10:09 +0000] 21400 MainThread agent ERROR Heartbeating to (ipaddress):None failed.
Traceback (most recent call last):
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.16.2-py2.7.egg/cmf/agent.py", line 1434, in _send_heartbeat
self.max_cert_depth)
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.16.2-py2.7.egg/cmf/https.py", line 138, in __init__
self.conn.connect()
File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/M2Crypto-0.24.0-py2.7-linux-x86_64.egg/M2Crypto/httpslib.py", line 74, in connect
raise error
error: [Errno 111] Connection refused

 

But i have set the port number in the ini file:

[General]
# Hostname of the CM server.
server_host=*ipaddress*

# Port that the CM server is listening on.
server_port=7180

I am not able to understand why it is picking none instead of port number. Even am not sure if this is the issue am thinking or some other.

MY ports 7180, 7182,9000 are all open and firewall is disabled too.

 

Please help me out.. 

1 REPLY 1

Super Collaborator

Hi @ruthika ,

 

Thanks for reaching out to Cloudera community.

 

The server_port needs to be set to 7182 in the /etc/cloudera-scm-agent/config.ini. CM has an agent heartbeat server which listens on 7182 to accept agent heartbeat.

 

Please modify the port and then restart CM agent and see if that helps.

 

Also, please take a look at below doc for the ports used by CM:

https://docs.cloudera.com/documentation/enterprise/latest/topics/cm_ig_ports_cm.html#cm_cn_ports

 

Hope this helps!

Li

Li Wang, Technical Solution Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:

Terms of Service

Community Guidelines

How to use the forum