Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

unable to upgrade via ambari

unable to upgrade via ambari

New Contributor

3430-screen-shot-2016-04-14-at-124232-am.png

I upgraded ambari from 2.0 to 2.2.1 and i am facing issues while adding a new repo to upgrade the hdp cluster

It throws this error on the UI

3430-screen-shot-2016-04-14-at-124232-am.pngscreen-shot-2016-04-14-at-124232-am.png(125.3 kB)

the logs on the server show this error

14 Apr 2016 00:18:56,271 ERROR [qtp-ambari-client-466] AbstractResourceProvider:159 - Couldn't retrieve Current stack entry from Map. 14 Apr 2016 00:18:56,280 ERROR [qtp-ambari-client-466] ReadHandler:91 - Caught a runtime exception executing a query java.lang.NullPointerException at org.apache.ambari.server.controller.internal.CompatibleRepositoryVersionResourceProvider.getResources(CompatibleRepositoryVersionResourceProvider.java:154) at org.apache.ambari.server.controller.internal.ClusterControllerImpl$ExtendedResourceProviderWrapper.queryForResources(ClusterControllerImpl.java:945) at org.apache.ambari.server.controller.internal.ClusterControllerImpl.getResources(ClusterControllerImpl.java:132) at org.apache.ambari.server.api.query.QueryImpl.doQuery(QueryImpl.java:508) at org.apache.ambari.server.api.query.QueryImpl.queryForSubResources(QueryImpl.java:463) at org.apache.ambari.server.api.query.QueryImpl.queryForSubResources(QueryImpl.java:482) at org.apache.ambari.server.api.query.QueryImpl.queryForResources(QueryImpl.java:436) at org.apache.ambari.server.api.query.QueryImpl.execute(QueryImpl.java:216) at org.apache.ambari.server.api.handlers.ReadHandler.handleRequest(ReadHandler.java:68) at org.apache.ambari.server.api.services.BaseRequest.process(BaseRequest.java:135) at org.apache.ambari.server.api.services.BaseService.handleRequest(BaseService.java:106) at org.apache.ambari.server.api.services.BaseService.handleRequest(BaseService.java:75) at org.apache.ambari.server.api.services.StacksService.getStacks(StacksService.java:47) at sun.reflect.GeneratedMethodAccessor139.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:497)

Any pointers ?

Jabir

4 REPLIES 4

Re: unable to upgrade via ambari

New Contributor

yes multiple times

Re: unable to upgrade via ambari

Did the upgrade go ok? Could you please check if "DB Consistency Check" passed when ambari-server is started? You can find this in ambari-server.log

Re: unable to upgrade via ambari

@jabir ahmed

I hope you have already tried restarting ambari-server/agent.

Re: unable to upgrade via ambari

New Contributor

@jabir ahmed Please file an internal JIRA and assign it to me.