Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

upgrade ambari to 2.6.0 failed due to schema

Explorer

I'm trying upgrade ambari-server and ambari-agent from 2.2.2 to 2.6 in Centos 7.

Refered to official document , I progressed smoothly until the command "ambari-server upgrade",And the /var/log/ambari-server/ambari-server.log shows:

17 Nov 2017 14:03:37,055  INFO [main] LockFactory:53 - Lock profiling is disabled
17 Nov 2017 14:03:37,062  INFO [main] SchemaUpgradeHelper:394 - Upgrading schema to target version = 2.6.0.0
17 Nov 2017 14:03:37,082  INFO [main] SchemaUpgradeHelper:403 - Upgrading schema from source version = 2.2.2
17 Nov 2017 14:03:37,084 ERROR [main] SchemaUpgradeHelper:437 - Exception occurred during upgrade, failed
org.apache.ambari.server.AmbariException: Database version does not meet minimal upgrade requirements. Expected version should be not less than 2.4.0, current version is 2.2.2
        at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.main(SchemaUpgradeHelper.java:408)
17 Nov 2017 14:05:09,089  INFO [main] AmbariServer:207 - Found org/apache/ambari/server/controller/AmbariServer.class class in file:/usr/lib/ambari-server/ambari-server-2.6.0.0.267.jar!/org/apache/ambari/server/controller/AmbariServer.class
Ambari-server 2.2.2
HDP 2.4.3.0-227
Postgres  9.2.18

It looks like that the least version before upgrading to 2.6 is 2.4. But I notice this page imply the version after 2.2.0 is valid for upgrading. Someone have an idea?

1 ACCEPTED SOLUTION

Super Mentor

@Nick One

You must first upgrade to HDP 2.4 or higher using Ambari 2.5.2,2.4.3, 2.2.2, 2.2.1, 2.2, 2.1, or 2.0 before upgrading to Ambari 2.6

Please refer to the following Doc for more detailed info on this which states the same: https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.0.0/bk_ambari-upgrade/content/ambari_upgrade_gu...

View solution in original post

4 REPLIES 4

Super Mentor

@Nick One

You must first upgrade to HDP 2.4 or higher using Ambari 2.5.2,2.4.3, 2.2.2, 2.2.1, 2.2, 2.1, or 2.0 before upgrading to Ambari 2.6

Please refer to the following Doc for more detailed info on this which states the same: https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.0.0/bk_ambari-upgrade/content/ambari_upgrade_gu...

Explorer

Not exactly, I'm using HDP 2.4.3. Maybe I shoud also upgrade the Ambari to 2.4 at first?

Super Mentor

@Nick One

Ambari Upgrade path should be following. You should upgrade from ambari 2.2.2 to Ambari 2.5 and then from ambari 2.5 to Ambari 2.6. For more information on the behaviour change please refer to :

https://issues.apache.org/jira/browse/AMBARI-21268

From Ambari 2.2   ---->   Ambari 2.5   ----> Ambari 2.6

Explorer

@Jay Kumar SenSharma

It works! I downgrade Ambari to 2.5.1 and run 'ambari-server upgrade'. After successful completion, I upgrade Ambari to 2.6.0 and run 'ambari-server upgrade' again. This time the server startup without problem. Thank you for the solution.