Support Questions
Find answers, ask questions, and share your expertise

what version of setuptools required for Metron TP1, getting error on ansible-playbook step in vagrant up

Solved Go to solution
Highlighted

what version of setuptools required for Metron TP1, getting error on ansible-playbook step in vagrant up

Mentor
Unexpected Exception: (setuptools 1.1.6 (/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python), Requirement.parse('setuptools>=11.3'))
the full traceback was:


Traceback (most recent call last):
  File "/usr/local/bin/ansible-playbook", line 72, in <module>
    mycli = getattr(__import__("ansible.cli.%s" % sub, fromlist=[myclass]), myclass)
  File "/Library/Python/2.7/site-packages/ansible/cli/playbook.py", line 30, in <module>
    from ansible.executor.playbook_executor import PlaybookExecutor
  File "/Library/Python/2.7/site-packages/ansible/executor/playbook_executor.py", line 30, in <module>
    from ansible.executor.task_queue_manager import TaskQueueManager
  File "/Library/Python/2.7/site-packages/ansible/executor/task_queue_manager.py", line 29, in <module>
    from ansible.executor.play_iterator import PlayIterator
  File "/Library/Python/2.7/site-packages/ansible/executor/play_iterator.py", line 29, in <module>
    from ansible.playbook.block import Block
  File "/Library/Python/2.7/site-packages/ansible/playbook/__init__.py", line 25, in <module>
    from ansible.playbook.play import Play
  File "/Library/Python/2.7/site-packages/ansible/playbook/play.py", line 27, in <module>
    from ansible.playbook.base import Base
  File "/Library/Python/2.7/site-packages/ansible/playbook/base.py", line 35, in <module>
    from ansible.parsing.dataloader import DataLoader
  File "/Library/Python/2.7/site-packages/ansible/parsing/dataloader.py", line 33, in <module>
    from ansible.parsing.vault import VaultLib
  File "/Library/Python/2.7/site-packages/ansible/parsing/vault/__init__.py", line 66, in <module>
    from cryptography.hazmat.primitives.hashes import SHA256 as c_SHA256
  File "/Library/Python/2.7/site-packages/cryptography/hazmat/primitives/hashes.py", line 15, in <module>
    from cryptography.hazmat.backends.interfaces import HashBackend
  File "/Library/Python/2.7/site-packages/cryptography/hazmat/backends/__init__.py", line 7, in <module>
    import pkg_resources
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 2797, in <module>
    parse_requirements(__requires__), Environment()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 580, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
VersionConflict: (setuptools 1.1.6 (/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python), Requirement.parse('setuptools>=11.3'))
1 ACCEPTED SOLUTION

Accepted Solutions

Re: what version of setuptools required for Metron TP1, getting error on ansible-playbook step in vagrant up

Rising Star

If what @Henry Sowell suggested doesn't help, would you do the following:

  1. Pull in current master
  2. Run PROJECTDIR/metron-deployment/scripts/platform-info.sh and attach the output

You may have some versioning issues.

Thanks!

View solution in original post

7 REPLIES 7
Highlighted

Re: what version of setuptools required for Metron TP1, getting error on ansible-playbook step in vagrant up

Explorer
Highlighted

Re: what version of setuptools required for Metron TP1, getting error on ansible-playbook step in vagrant up

Mentor

unfortunately that did not work @Henry Sowell and @David Lyle

$ sudo pip install --upgrade setuptools --user python
Password:
The directory '/Users/aervits/Library/Caches/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/Users/aervits/Library/Caches/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Collecting setuptools
  Downloading setuptools-21.0.0-py2.py3-none-any.whl (509kB)
    100% |████████████████████████████████| 512kB 673kB/s
Requirement already up-to-date: python in /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload
Installing collected packages: setuptools
Successfully installed setuptools-1.1.6

$ sudo -H pip install --upgrade setuptools --user python
Collecting setuptools
  Using cached setuptools-21.0.0-py2.py3-none-any.whl
Requirement already up-to-date: python in /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/lib-dynload
Installing collected packages: setuptools
Successfully installed setuptools-1.1.6

Re: what version of setuptools required for Metron TP1, getting error on ansible-playbook step in vagrant up

Rising Star

If what @Henry Sowell suggested doesn't help, would you do the following:

  1. Pull in current master
  2. Run PROJECTDIR/metron-deployment/scripts/platform-info.sh and attach the output

You may have some versioning issues.

Thanks!

View solution in original post

Highlighted

Re: what version of setuptools required for Metron TP1, getting error on ansible-playbook step in vagrant up

Mentor

I'll try this out and let you guys know. Thanks!

Highlighted

Re: what version of setuptools required for Metron TP1, getting error on ansible-playbook step in vagrant up

Mentor
Metron 0.1BETA
--
* master
--
commit ec431b8dd2a6bb5c275ef3825c1c7516ec4ffce9
Author: merrimanr <merrimanr@gmail.com>
Date:   Fri May 6 13:38:21 2016 -0400


    METRON-129 Created Vagrant images for Metron development (merrimanr via nickwallen) closes apache/incubator-metron#105
--
--
Unexpected Exception: (setuptools 1.1.6 (/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python), Requirement.parse('setuptools>=11.3'))
the full traceback was:


Traceback (most recent call last):
  File "/usr/local/bin/ansible", line 74, in <module>
    from ansible.cli.adhoc import AdHocCLI as mycli
  File "/Library/Python/2.7/site-packages/ansible/cli/adhoc.py", line 28, in <module>
    from ansible.executor.task_queue_manager import TaskQueueManager
  File "/Library/Python/2.7/site-packages/ansible/executor/task_queue_manager.py", line 29, in <module>
    from ansible.executor.play_iterator import PlayIterator
  File "/Library/Python/2.7/site-packages/ansible/executor/play_iterator.py", line 29, in <module>
    from ansible.playbook.block import Block
  File "/Library/Python/2.7/site-packages/ansible/playbook/__init__.py", line 25, in <module>
    from ansible.playbook.play import Play
  File "/Library/Python/2.7/site-packages/ansible/playbook/play.py", line 27, in <module>
    from ansible.playbook.base import Base
  File "/Library/Python/2.7/site-packages/ansible/playbook/base.py", line 35, in <module>
    from ansible.parsing.dataloader import DataLoader
  File "/Library/Python/2.7/site-packages/ansible/parsing/dataloader.py", line 33, in <module>
    from ansible.parsing.vault import VaultLib
  File "/Library/Python/2.7/site-packages/ansible/parsing/vault/__init__.py", line 66, in <module>
    from cryptography.hazmat.primitives.hashes import SHA256 as c_SHA256
  File "/Library/Python/2.7/site-packages/cryptography/hazmat/primitives/hashes.py", line 15, in <module>
    from cryptography.hazmat.backends.interfaces import HashBackend
  File "/Library/Python/2.7/site-packages/cryptography/hazmat/backends/__init__.py", line 7, in <module>
    import pkg_resources
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 2797, in <module>
    parse_requirements(__requires__), Environment()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 580, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
VersionConflict: (setuptools 1.1.6 (/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python), Requirement.parse('setuptools>=11.3'))
--
Vagrant 1.8.1
--
Python 2.7.10
--
Apache Maven 3.3.3 (7994120775791599e205a5524ec3e0dfe41d4a06; 2015-04-22T07:57:37-04:00)
Maven home: /usr/local/apache-maven-3.3.3
Java version: 1.8.0_51, vendor: Oracle Corporation
Java home: /Library/Java/JavaVirtualMachines/jdk1.8.0_51.jdk/Contents/Home/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "mac os x", version: "10.10.5", arch: "x86_64", family: "mac"
--
Darwin hw12107.local 14.5.0 Darwin Kernel Version 14.5.0: Tue Sep  1 21:23:09 PDT 2015; root:xnu-2782.50.1~1/RELEASE_X86_64 x86_64

Highlighted

Re: what version of setuptools required for Metron TP1, getting error on ansible-playbook step in vagrant up

Rising Star

Thanks for that. It looks like there is a version mismatch in your Python environment. If you do a python --version, what do you get?

Highlighted

Re: what version of setuptools required for Metron TP1, getting error on ansible-playbook step in vagrant up

Mentor

@David Lyle thanks, you're correct there's a version mismatch but not with Python. I had issues with easy_install, removed both references to it and installed setuptools through pip. Though I cannot comment on the final result, I'm passed this issue.

cd /usr/local/bin
rm -rf easy_install*
curl https://bootstrap.pypa.io/ez_setup.py -o - | python