Support Questions

Find answers, ask questions, and share your expertise

when i am trying to enable kerberos on HA cluster in the last step of restarting the services is failing.


Hi i am using HDP-2.5,i have setup three node cluster .in my cluster i have instaleed services like HDFS,YARN,MAPREDUCE,TEZ,HIVE,HBASE,ZOOKEEPER,AMBARI INFRA,AMBARI METRICS,KNOX,RANGER AND SPARX. and enabled high availability. when i was tried to enable the kerberos on cluster it is throwing error in the last step that is start all that zookeeper is not starting.please find exhibit and error log and please help me out.thanks in advance.



@pavan p

If you have exited out of the Enable Kerberos Wizard, make sure all services are shut down (according to Ambari). Then take a look at to see if the Zookeeper Server instance on there has shut down. Once Zookeeper has been confirmed to have been shutdown, try to start Zookeeper using Ambari. If it comes up, use Ambari to execute the Zookeeper service check.

If the Zookeeper server does not start up, take a look at the log (/var/log/zookeeper/zookeeper.out) and see if there are any interesting errors in there. Additionally, you can attach the log file to this question so we can take a look. Maybe there is something wrong with the Zookeeper Kerberos Identity.


Hi i have done the steps which you have mentioned.but again it is failing.

but i can able to start zookeeper before enabling kerberose .whenever i start enabling kerberos zookeper is not comming up..

i am attaching zookeper.out,and all the ambari steps which i have done.please help me.

I am not sure what the issue could be. I just walked through this on a local cluster and it worked smoothly for me.

Maybe try to disable Kerberos, make sure all starts up ok, then re-enabled Kerberos.