Support Questions
Find answers, ask questions, and share your expertise

when i run 'yum install ambari-server' command, there occur some error

Explorer

when i run 'yum install ambari-server' command, there occur some error like this:

--> Finished Dependency Resolution Error: Package: ambari-server-2.4.1.0-0.x86_64 (Updates-ambari-2.4.1.0) Requires: python-xml You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

5 REPLIES 5

@Ye Jun

- Please try completely cleaning ambari as described in the thread: https://community.hortonworks.com/questions/1110/how-to-completely-remove-uninstall-ambari-and-hdp.h...

- The perform a clean

 yum clean all

- If required remove the old "/etc/yum.repos.d/ambari*" if present.

- Get the correct repos from: https://docs.hortonworks.com/HDPDocuments/Ambari-2.4.1.0/bk_ambari-upgrade/content/upgrade_ambari.ht...

Example:

- Verify if you have python installed properly on your OS (please share the output of "python --version" as well)

- Now retry the installation.

@Ye Jun

I see that the following is mentioned as a dependency:

rpm.dependency.list.suse=postgresql-server >=8.1,\nRequires: openssl,\nRequires: python-xml,\nRequires: python >=2.6

https://github.com/apache/ambari/blob/release-2.4.1/ambari-server/src/main/package/dependencies.prop...

.

- Which OS are you using and the exact python version?

Explorer

os is centos 7 and python is 2.7.5, i only change ambari-web/app/message.js

Explorer

os is centos 7 and python 2.7.5, i only change ambari-web/app/message.js

@Ye Jun

- As per the note: http://docs.hortonworks.com/HDPDocuments/Ambari-2.4.1.0/bk_ambari-installation/content/download_the_...

- When you install the Ambari Server, the PostgreSQL packages and dependencies must be available for install. These packages are typically available as part of your Operating System repositories. Please confirm you have the appropriate repositories available for the postgresql-server packages.

Similarly the openssl + python-xml dependencies also should come from the OS repository.