Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

why CURL running druid job as "druid" not unix end user?

why CURL running druid job as "druid" not unix end user?

New Contributor
Dear Druid-User group,
I am trying to update a DRUID segment data.
 
CURL druid job creates segment files as user"druid" whereas my CURL job was run by unix end-user. how can force druid job to create segment files as end-user?
next problem is:
when I insert to DRUID table via HIVE external table, it does not create additional druid index files. the HIVE session hangs forever due to permission conflict in the interval directory that is "druid" vs "end-user"
 
To solve my above problem i want to disable the druid segment programmatically and fresh insert from HIVE . 
To disable a segment I tried the below two methods, nothing works:"
I tried  by providing interval value as CURL - X DELETE http://mydruidsever:8081/druid/coordinator/v1/datasources/{DSourceNAME}/intervals/"2020-10-06T00.00.000Z/ 2020-10-07T00.00.000Z"
also I tried...
curl -X 'POST' -H 'Content-Type:applications/json' -d '{ "interval" : "2020-10-06T00.00.000Z/ 2020-10-07T00.00.000Z" }' http://mydruidsever:8081/druid/coordinator/v1/datasources/{DSourceNAME}/markUnused
 
what wrong with the above interval method?????? but works fine when i pass the segment id to   CURL - X DELETE http://complete_segment_url?
 
 Thanks in advance for your help. 

--

-Sachi Padhi

Don't have an account?
Coming from Hortonworks? Activate your account here