Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

why HDP upgrade ( both rolling & express )to 2.4.2.0 did not succeed on 2 hosts??

Highlighted

why HDP upgrade ( both rolling & express )to 2.4.2.0 did not succeed on 2 hosts??

Contributor

While performing upgrade(both rolling & express) from 2.3.4.7. to 2.4.2.0. , the upgrade process failed on 2 hosts at the stage of Finalize Upgrade Pre-check with the errors given : slave0: HBASE/HBASE_REGIONSERVER reports 2.3.4.7-4 & slave1: HIVE/HIVE_METASTORE reports 2.3.4.7-4(PFA). Also tried the options to skip all service check failures but it still throws the same error while upgrading. Please note that i have performed all pre-upgarde necessary steps. How to resolve these errors to perform upgrade successfully?Kindly help.


express-upgrade.png
2 REPLIES 2

Re: why HDP upgrade ( both rolling & express )to 2.4.2.0 did not succeed on 2 hosts??

@hardik desai

Can you please check if there are any error logs displayed in stderr ? or ambari server upgrade logs ?

Also please make sure if the services running on the nodes are running fine. Check the node logs.

Re: why HDP upgrade ( both rolling & express )to 2.4.2.0 did not succeed on 2 hosts??

Contributor

@Sagar Shimpi, there are logs available in stderr saying version mismtach for Hbase & Hive.PFA for the more details.Made sure the services are running on the nodes properly.