Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

with the following command sqoop job is running fine but while executing getting invalid username or password(both are correct)

with the following command sqoop job is running fine but while executing getting invalid username or password(both are correct)

New Contributor

sqooping to hdfs from oracle DB

Job created susccessfully but while executing its showing an error invalid username or password.

sqoop job -Dmapred.job.queue.name=*** -Dorg.apache.sqoop.credentials.loader.class=org.apache.sqoop.util.password.CryptoFileLoader -Dorg.apache.sqoop.credentials.loader.crypto.passphrase=*** --create jobname -- import --connect ************ --password-file file:///tmp/pass.enc --username *** --table *** --check-column *** --incremental append --last-value *** --target-dir **** --split-by **** --verbose

sqoop job --exec jobname

Error:invalid username/password; logon denied

Thanks in advance

2 REPLIES 2

Re: with the following command sqoop job is running fine but while executing getting invalid username or password(both are correct)

Super Mentor

@Naveen Kumar

Sometimes it happens that the "--password-file" has some hidden characters (not visible in few editors) Hence please make sure that the password is present without unwanted hidden characters in it.

You can try generating the password file as following and then use it in your scoop command.

# echo -n "your_password" > /tmp/pass.enc

.

Re: with the following command sqoop job is running fine but while executing getting invalid username or password(both are correct)

New Contributor

hi jay, thanks for reply.Checked and password is correct.