Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

yarn resource manage HA not working

Solved Go to solution
Highlighted

yarn resource manage HA not working

Master Collaborator

using Ambari I enabled successfully the resource manage HA , but when I see the yarn-site.xml I still see this property as false ?

    <property>
      <name>yarn.resourcemanager.ha.enabled</name>
      <value>false</value>
    </property>
1 ACCEPTED SOLUTION

Accepted Solutions

Re: yarn resource manage HA not working

Expert Contributor

@Sami Ahmad

1. can you please let us know the version of ambari that you are using ?

2. Also can you check the current value for the same property (yarn.resourcemanager.ha.enabled) on YARN service config page in Ambari ?

3. Can you view the config version that enabled RM HA and check the same property's value ? you can do this from UI and API.

UI: enable-rm-ha.png

API:

http://localhost:8080/api/v1/clusters/c1/configurations/service_config_versions?service_name=YARN&se...

Once you get the response from API, do a lookup for the property value

7 REPLIES 7

Re: yarn resource manage HA not working

Expert Contributor

@Sami Ahmad

Please restart your yarn services on the cluster to reflect the changes

Re: yarn resource manage HA not working

Master Collaborator

I did, I restarted ambari and all the services in ambari , still showing false.

Re: yarn resource manage HA not working

Master Collaborator

strange , after I installed it second time now its showing as true

Re: yarn resource manage HA not working

Expert Contributor

@Sami Ahmad

1. can you please let us know the version of ambari that you are using ?

2. Also can you check the current value for the same property (yarn.resourcemanager.ha.enabled) on YARN service config page in Ambari ?

3. Can you view the config version that enabled RM HA and check the same property's value ? you can do this from UI and API.

UI: enable-rm-ha.png

API:

http://localhost:8080/api/v1/clusters/c1/configurations/service_config_versions?service_name=YARN&se...

Once you get the response from API, do a lookup for the property value

Re: yarn resource manage HA not working

Master Collaborator

yarn config menu in Ambari is showing this property as false

11892-ps92t.png

Re: yarn resource manage HA not working

Expert Contributor

@Sami Ahmad

can you let us know the value of the property when yarn RM HA was done. This can be achieved by using the API is described in my last comment

http://localhost:8080/api/v1/clusters/c1/configurations/service_config_versions?service_name=YARN&se...

I am trying to understand if that yarn property was set to true when RAM HA was done for the very first time and then later got reverted to false OR value of that property was false even when RM HA was completed

We can know that by looking into the property value by using above API as that service config version is created when YARN RM HA is completed.

Also let us know ambari version. It allows us to look into the correct version of ambari code and verify if it's a bug specific to the ambari version that you are using or not.

Re: yarn resource manage HA not working

Master Collaborator

it does show the secondary name node though and with no errors and the journal nodes

11893-hx9tu.png