Support Questions
Find answers, ask questions, and share your expertise

zeppelin tutorial, "hive interpreter not found"

Solved Go to solution
Highlighted

zeppelin tutorial, "hive interpreter not found"

Contributor

I see a green "connected" icon.

I check the zeppelin interpreter page, and hive listed.

I restart it from that page. I can run the hive cli. I check the yarn application list and there is nothing running.

when I try to run simple query from the tutorial

%hive

SELECT * FROM finalresult

I get "hive interpreter not found"

stack trace from the zeppelin log file:

ERROR [2016-05-02 15:27:45,626] ({qtp61918702-31} NotebookServer.java[afterStatusChange]:800) - Error org.apache.zeppelin.interpreter.InterpreterException: hive interpreter not found at org.apache.zeppelin.notebook.NoteInterpreterLoader.get(NoteInterpreterLoader.java:148) at org.apache.zeppelin.notebook.Note.run(Note.java:368) at org.apache.zeppelin.socket.NotebookServer.runParagraph(NotebookServer.java:711) at org.apache.zeppelin.socket.NotebookServer.onMessage(NotebookServer.java:143) at org.apache.zeppelin.socket.NotebookSocket.onMessage(NotebookSocket.java:56) at org.eclipse.jetty.websocket.WebSocketConnectionRFC6455$WSFrameHandler.onFrame(WebSocketConnectionRFC6455.java:835) at org.eclipse.jetty.websocket.WebSocketParserRFC6455.parseNext(WebSocketParserRFC6455.java:349) at org.eclipse.jetty.websocket.WebSocketConnectionRFC6455.handle(WebSocketConnectionRFC6455.java:225) at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:667) at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:52) at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608) at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543) at java.lang.Thread.run(Thread.java:745)

1 ACCEPTED SOLUTION

Accepted Solutions

Re: zeppelin tutorial, "hive interpreter not found"

Contributor

solved it. the problem is introduced by copy/paste text from the tutorial page. it must introduce some garbage characters. someone else noted this as a problem with starting one of the other interpreters.

View solution in original post

8 REPLIES 8
Highlighted

Re: zeppelin tutorial, "hive interpreter not found"

can you make sure tt the top of the tutorial page, open the gear icon and make sure "hive %hive..." is blue and click save. If not can you share the description and config of your hive interpreter

Highlighted

Re: zeppelin tutorial, "hive interpreter not found"

Contributor

@nmaillard

thanks. checked as you say and all is as expected. tried again and got the same error. same stack trace.

If this helps, I can run spark from within zeppelin. Problem seems to be only with hive interpreter.

Re: zeppelin tutorial, "hive interpreter not found"

Contributor

solved it. the problem is introduced by copy/paste text from the tutorial page. it must introduce some garbage characters. someone else noted this as a problem with starting one of the other interpreters.

View solution in original post

Highlighted

Re: zeppelin tutorial, "hive interpreter not found"

New Contributor

It is working, thanks.

Highlighted

Re: zeppelin tutorial, "hive interpreter not found"

New Contributor

Thanks for the post. I faced similar issue and thought that something is wrong with the Interpreter settings. But it was due to some issue while copying the commands from the Tutorial site to Zeppelin workbook.

Highlighted

Re: zeppelin tutorial, "hive interpreter not found"

yes i had this problem also , if you type the code it will run but in copy paste there is a problem ,

how can i ask tutorials support to fix it ? or even mention that you have to type it yourself

Highlighted

Re: zeppelin tutorial, "hive interpreter not found"

@Fardin Behboudi Vaighan there was an issue with the script that we use to post the tutorial. It has been updated so this issue should be resolved. Please let us know if this is not the case. @jmedel

Highlighted

Re: zeppelin tutorial, "hive interpreter not found"

New Contributor

I does seem a little unkind to throw a curveball to people using a tutorial. But the problem seems to be carriage returns that come along for the ride during the copy and paste operation. If you delete 'em, it seems to work fine.