Reply
Contributor
Posts: 37
Registered: ‎10-27-2015

C6, Hue, MySQL, and RHEL6

The Cloudera Enterprise 6.x Release Notes Database Requirements states that:

 

  • Hue requires the default MySQL/MariaDB version (if used) of the operating system on which it is installed. For more information, see Hue Databases.

 

On RHEL6, this means that Hue requires MySQL version 5.1. But the rest of C6 requires the use of MySQL version 5.7.

 

Does this mean that for RHEL/CentOS 6, two different MySQL database installations will be required?  One for Hue and another for CM/ReportsManager/NavAudit/NavMeta/Hive/Oozie?

Posts: 933
Kudos: 28
Solutions: 16
Registered: ‎05-27-2014

Re: C6, Hue, MySQL, and RHEL6

Hi @mjarnold ,

 

Thanks for bringing this into our attention. I feel there is a conflict of documentation issue here. Please give me some time to clarify this with internal team and I will post an update.

 

Thanks,

Li

Li Wang, Technical Resolution Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:

Terms of Service

Community Guidelines

How to use the forum

Posts: 933
Kudos: 28
Solutions: 16
Registered: ‎05-27-2014

Re: C6, Hue, MySQL, and RHEL6

To follow up, I have filed a internal jira request to get our documentation team to take a look at this.

 

Thanks,

Li

Li Wang, Technical Resolution Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:

Terms of Service

Community Guidelines

How to use the forum

Contributor
Posts: 37
Registered: ‎10-27-2015

Re: C6, Hue, MySQL, and RHEL6

Thanks, Li!
Cloudera Employee
Posts: 98
Registered: ‎07-31-2013

Re: C6, Hue, MySQL, and RHEL6

It's a bit confusing and we should fix the docs.  You need the Mysql 5.1 libraries availble, but you can have Mysql 5.7 installed.  There is a compat rpm you can install instead.  Search for something like this in Yum or your rpms:

 

mysql-community-libs-compat-5.7.16-1.el7.x86_64.rpm

Highlighted
Contributor
Posts: 37
Registered: ‎10-27-2015

Re: C6, Hue, MySQL, and RHEL6

That particular package only comes from the MySQL Community repository.  Not from the OS repos or from the SCL repos.