Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 10-23-2018 06:32 AM
As we see the error is basically happening because the Port 53 Already Bind
2018-10-23 13:51:37,962 ERROR dns.PrivilegedRegistryDNSStarter (PrivilegedRegistryDNSStarter.java:init(61)) - Error initializing Registry DNS java.net.BindException: Problem binding to [node.b2be.com:53] java.net.BindException: Address already in use; For more details see: http://wiki.apache.org/hadoop/BindException
.
So please check if your host where you are planning to run the "YARN Registry DNS" has the port 53 available Or some other process is already using that port?
# netstat -tnlpa | grep 53
.
OR try verifying if you can open the port 53 using simple program like "nc" (netcat) onn that host? Or do you see Already Used port error there as well?
# nc -l `hostname -f` 53 Ncat: bind to 10.10.20.30:53: Address already in use. QUITTING.
.
If yes then Try changing the port to see if it works Or stop the other process which is using that port?
Check the value of the following properyy in your YARN configs
"hadoop.registry.dns.bind-port". (registry.dns.bind-port) default value = 53
.