New Contributor
Posts: 3
Registered: ‎11-22-2014
WARNINGS: Backend 0:Unknown disk id. This will negatively affect performance

Hi all,
When I use both hive and impala to query 10000 lines data from one table which has 80000 lines. The result is like following:

1) First query using Hive:

9995 name9995
9996 name9996
9997 name9997
9998 name9998
9999 name9999
Time taken: 1.242 seconds, Fetched: 10000 row(s)
hive>

2) Second query using Hive:

9995 name9995
9996 name9996
9997 name9997
9998 name9998
9999 name9999
Time taken: 0.092 seconds, Fetched: 10000 row(s)

3) First query using impala:

| 9995 | name9995 |
| 9996 | name9996 |
| 9997 | name9997 |
| 9998 | name9998 |
| 9999 | name9999 |
+------+----------+
WARNINGS: Backend 0:Unknown disk id. This will negatively affect performance. Check your hdfs settings to enable block location metadata.

Fetched 10000 row(s) in 2.45s

4) Second query using impala:

| 9995 | name9995 |
| 9996 | name9996 |
| 9997 | name9997 |
| 9998 | name9998 |
| 9999 | name9999 |
+------+----------+
WARNINGS: Backend 0:Unknown disk id. This will negatively affect performance. Check your hdfs settings to enable block location metadata.

Fetched 10000 row(s) in 2.45s

I noted the warnings, and i have already set the value of dfs.datanode.hdfs-blocks-metadata.enabled true.
This is the part of the configuration pasted from page https://192.168.10.11:25000/hadoop-varz
dfs.datanode.hdfs-blocks-metadata.enabled true
Sorry for that I cann't adjust the format of the form. I don't know why impala still reports this warnings when my hdfs settings to enable block location metadata
By the way, number of machines of impala cluster is 4, machine whose ip is 192.168.10.11 runs statestore, impalad, catalogd, machine whose ip are from 192.168.10.12-192.168.10.14 run impalad service. And I use the way of building tar ball of impala-2.0.0-cdh5.2.0 which is downloaded from github. Also I replace the cdh hadoop using apache hadoop.
Do I use impala rightly?

Regards

Who Me Too'd this topic