Support Questions
Find answers, ask questions, and share your expertise

Who agreed with this topic

Cannot restart namenode: Failed to load an FSImage file

Explorer

I have Cluster Express with 1 master role, 1 management role and 6 worker roles. My Namenode and Master showed not running and I cannot restart the Namenode. Error below:

 

2015-11-29 19:27:32,758 FATAL org.apache.hadoop.hdfs.server.namenode.NameNode: Exception in namenode join
java.io.IOException: Failed to load an FSImage file!
	at org.apache.hadoop.hdfs.server.namenode.FSImage.loadFSImage(FSImage.java:657)
	at org.apache.hadoop.hdfs.server.namenode.FSImage.recoverTransitionRead(FSImage.java:275)
	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.loadFSImage(FSNamesystem.java:880)
	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.loadFromDisk(FSNamesystem.java:639)
	at org.apache.hadoop.hdfs.server.namenode.NameNode.loadNamesystem(NameNode.java:500)
	at org.apache.hadoop.hdfs.server.namenode.NameNode.initialize(NameNode.java:556)
	at org.apache.hadoop.hdfs.server.namenode.NameNode.<init>(NameNode.java:721)
	at org.apache.hadoop.hdfs.server.namenode.NameNode.<init>(NameNode.java:705)
	at org.apache.hadoop.hdfs.server.namenode.NameNode.createNameNode(NameNode.java:1355)
	at org.apache.hadoop.hdfs.server.namenode.NameNode.main(NameNode.java:1421)

 

I ssh'ed into the master role VM and tried to fix it manually:

 

hdfs namenode -recover

But it is still the same. Let me know where I should troubleshoot next. Thanks

 

 

 

 

 

Who agreed with this topic