Support Questions
Find answers, ask questions, and share your expertise

Who agreed with this topic

apt-get update not working after creating local repository

Explorer

Apology is this sound stupid. 

 

I have a previous installation of CDH5.5.1 which I have uninstalled and wanted to do a new fresh installation using a local repository.

 

I've created a local repository which can be accessed through browser. To do that I've created a file named /custom-repo.list  inside /etc/apt/sources.list.d/   with the following content in it ..

 

deb [arch=amd64] http://xxx.xx.xx.xxx/cm5.5.1 trusty-cm5.5.1 contrib

deb-src [arch=amd64] http://xxx.xx.xx.xxx/cm5.5.1 trusty-cm5.5.1 contrib

 

after that when I do apt-get update it shows a error like:

 

W: GPG error: http://xxx.xx.xx.xxx trusty-cm5.5.1 InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 327574EE02A818DD

  

I tried running 

$ apt-get clean

$ rm -rf /var/cache/apt/*

$ rm -rf /var/lib/apt/lists/*

 

But I am keep getting the same error as above, commenting  the repository entry from custom-repo.list  seems to resolve this. But as soon as I bring that back the same error is thorwn. 

 

What m I doing wromg here? could this happen due to improper uninstallation ? 

I am stuck at this and not able to move forward with the installation. any help would be highly appreciated

Please advice

 

 

Who agreed with this topic