Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Archives of Support Questions (Read Only)

This is an archived board for historical reference. Information and links may no longer be available or relevant
Announcements
This board is archived and read-only for historical reference. To ask a new question, please post a new topic on the appropriate active board.

Who agreed with this topic

CHD5.7:ERROR while starting NodeManager

avatar
New Contributor

Starting NODEMANAGER is failing with the below ERROR. 3 Node cluster with running with CDH5.7

org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger	registered UNIX signal handlers for [TERM, HUP, INT]
org.apache.hadoop.service.AbstractService	Service NodeManager failed in state INITED; cause: EPERM: Operation not permitted EPERM: Operation not permitted at org.apache.hadoop.io.nativeio.NativeIO$POSIX.chmod​Impl(Native Method) at org.apache.hadoop.io.nativeio.NativeIO$POSIX.chmod​(NativeIO.java:230) at org.apache.hadoop.fs.RawLocalFileSystem.setPermiss​ion(RawLocalFileSystem.java:660) at org.apache.hadoop.fs.RawLocalFileSystem.mkdirs(Raw​LocalFileSystem.java:452) at org.apache.hadoop.fs.FilterFileSystem.mkdirs(Filte​rFileSystem.java:309) at org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger.initAndStartRecoveryStore(NodeManager.java:152​) at org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger.serviceInit(NodeManager.java:195) at org.apache.hadoop.service.AbstractService.init(Abs​tractService.java:163) at org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger.initAndStartNodeManager(NodeManager.java:474) at org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger.main(NodeManager.java:521)
org.apache.hadoop.service.AbstractService	When stopping the service NodeManager : java.lang.NullPointerException java.lang.NullPointerException at org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger.stopRecoveryStore(NodeManager.java:162) at org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger.serviceStop(NodeManager.java:275) at org.apache.hadoop.service.AbstractService.stop(Abs​tractService.java:221) at org.apache.hadoop.service.ServiceOperations.stop(S​erviceOperations.java:52) at org.apache.hadoop.service.ServiceOperations.stopQu​ietly(ServiceOperations.java:80) at org.apache.hadoop.service.AbstractService.init(Abs​tractService.java:171) at org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger.initAndStartNodeManager(NodeManager.java:474) at org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger.main(NodeManager.java:521)
org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger	Error starting NodeManager org.apache.hadoop.service.ServiceStateException: EPERM: Operation not permitted at org.apache.hadoop.service.ServiceStateException.co​nvert(ServiceStateException.java:59) at org.apache.hadoop.service.AbstractService.init(Abs​tractService.java:172) at org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger.initAndStartNodeManager(NodeManager.java:474) at org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger.main(NodeManager.java:521) Caused by: EPERM: Operation not permitted at org.apache.hadoop.io.nativeio.NativeIO$POSIX.chmod​Impl(Native Method) at org.apache.hadoop.io.nativeio.NativeIO$POSIX.chmod​(NativeIO.java:230) at org.apache.hadoop.fs.RawLocalFileSystem.setPermiss​ion(RawLocalFileSystem.java:660) at org.apache.hadoop.fs.RawLocalFileSystem.mkdirs(Raw​LocalFileSystem.java:452) at org.apache.hadoop.fs.FilterFileSystem.mkdirs(Filte​rFileSystem.java:309) at org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger.initAndStartRecoveryStore(NodeManager.java:152​) at org.apache.hadoop.yarn.server.nodemanager.NodeMana​ger.serviceInit(NodeManager.java:195) at org.apache.hadoop.service.AbstractService.init(Abs​tractService.java:163) ... 2 more
Who agreed with this topic