New Contributor
Posts: 3
Registered: ‎12-28-2017
Kubernetes not running in a new installation

Hi!

 

I am installing Cloudera DSW on 2 new machines in an existing cluster via Cloudera Manager.

All my services (docker daemons, master, worker, application) are green. But the status is bad, stating "Failed to connect to Kubernetes Master api.". Looks like Kubernetes is not running at all. When I try to do "kubectl config view", it is pretty empty - of all the values only the version is set. When I try "kubectl cluster-info", I get the expected error "The connection to the server localhost:8080 was refused" (no one is listening, the API is not up). I tried searching for the Kubernetes admin.conf file and did not find it in the system. I tried "kubeadm init", but it can't connect to the Internet. The server is running behind a proxy, but the proxy seettings are in the environment variables, and I have also added them to the Workbench settings. I am at a loss here and don't know anymore where to look or what to try. Any help would be appreciated. I can provide all necessary info about the installation, of course, I tried specifying the important parts.

Who Me Too'd this topic