Support Questions

Find answers, ask questions, and share your expertise

Apache Metron 0.4.x installation in Ubuntu not working


We have tried Metron 0.3.1 in Ubuntu HDP cluster based on the steps provided in the below link,

Its works. But Metron 0.3.x does not have Metron UI so we thought to switch back into Metron 0.4.x.

We have followed the same steps all the topology are started except elasticsearch indexing topology,

Strange class not found exception without much details,

Exception in thread "main" java.lang.RuntimeException: java.lang.ClassNotFoundException: at at org.apache.storm.StormSubmitter.populateCredentials( at org.apache.storm.StormSubmitter.submitTopologyAs( at org.apache.storm.StormSubmitter.submitTopology( at org.apache.storm.flux.Flux.runCli( at org.apache.storm.flux.Flux.main( Caused by: java.lang.ClassNotFoundException: at java.lang.Class.forName0(Native Method) at java.lang.Class.forName( at

Please find the attached log for reference.

Metron UI can't able to start in Ubuntu 14.x. Direct me if there are any post related to that.





Super Mentor

@Uvaraj Seerangan

The "GetAutoCredentials" method where it is failing to find a class, Get all of the configured AutoCredential Plugins so Storm configurations need to be checked.

Based on the error trace it looks like the code is failing to determine the "" based on

Please check your storm config to findout what is the value set for "" property, Please refer to

"" => Set to a list of Java plugins that pack and unpack user credentials for Storm workers. This should be set to Please check the classes that are set to this property are included in the classpath.



Thanks @Jay Kumar SenSharma

I have added ""property in ambari but no luck,


Do we first configure storm for that "Configuring Authorization for Storm"

Is the ambari will take of this " Please check the classes that are set to this property are included in the classpath." ?

Please guide me on this.



Thanks @Jay Kumar SenSharma

I have fixed the issue and elasticsearch indexing topology now working. The issue because of in file,['']

It is provided empty if we are enabled kerberos then this has to be set with AutoTGT. If not just removing that property value will fix the issue,

instead of['']

In all the other properties value for is empty other than


By default it should be provided as empty like in the other properties.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.