Support Questions
Find answers, ask questions, and share your expertise

Blueprint - Registration Error

Expert Contributor

Hi!

It's good to be back here.. 🙂

I'm trying to create my cluster using blueprints, I'm stucked at repo registration using public repo....

{
  "status" : 400,
  "message" : "java.lang.IllegalArgumentException: Could not access base url . http://public-repo-1.hortonworks.com/HDP/ubuntu16/2.x/updates/2.6.4.0 . http://public-repo-1.hortonworks.com/HDP/ubuntu16/2.x/updates/2.6.4.0/dists/HDP-2.6.4.0/Release"
}       

Here's the json file

{
  "Repositories" : {
    "repo_name" : "HDP-2.6.4.0",
    "base_url" : "http://public-repo-1.hortonworks.com/HDP/ubuntu16/2.x/updates/2.6.4.0",
    "verify_base_url" : true
  }
}

Any help would be appreciated. Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

Expert Contributor

Issue fixed by setting up a local repository. Not sure why I'm having error when using public repo.

Thank for helping out!

View solution in original post

3 REPLIES 3

Mentor

@Michael Dennis "MD" Uanang

That URL is inaccessible is your host able to connect to the internet?

Have you setup and started your Ambari server?

Can you post contents of your /etc/apt/sources.list.d/ambari.list

Expert Contributor

Hi @Geoffrey Shelton Okot

That URL is inaccessible is your host able to connect to the internet?

Yes. I can download the VDF and hdp.list files from it. But when trying to access it via browser it got this

<Error>
<Code>NoSuchKey</Code>
<Message>The specified key does not exist.</Message>
"); vertical-align: bottom; height: 10px;"><Key>
HDP/ubuntu16/2.x/updates/2.6.4.0/dists/HDP-2.6.4.0/
</Key>
<RequestId>324F1BB13AAAF858</RequestId>
"); vertical-align: bottom; height: 10px;"><HostId>
jzXWBknZCZ+SyMzIlw4n0HDFiwykhvO5EPZmzONxou0CnaJVzxQQZLoDfgEOwVY8Q7mkSrZgJQc=
</HostId>
</Error>

Have you setup and started your Ambari server?

Yes.

Can you post contents of your /etc/apt/sources.list.d/ambari.list

cat /etc/apt/sources.list.d/hdp.list
# VERSION_NUMBER=2.6.4.0-91
deb http://public-repo-1.hortonworks.com/HDP/ubuntu16/2.x/updates/2.6.4.0 HDP main
deb http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.22/repos/ubuntu16 HDP-UTILS main
cat /etc/apt/sources.list.d/ambari.list
#VERSION_NUMBER=2.6.1.3-3
deb http://public-repo-1.hortonworks.com/ambari/ubuntu16/2.x/updates/2.6.1.3 Ambari main

Expert Contributor

Issue fixed by setting up a local repository. Not sure why I'm having error when using public repo.

Thank for helping out!

View solution in original post