Support Questions

Find answers, ask questions, and share your expertise

Couldn't resolve host ''

While taking Hbase tutorial from link:

and while downloading data file (dataset) using command:

curl -o ~/data.csv

I am getting below error message:

curl: (6) Couldn't resolve host ''

Could someone tell how to proceed ahead


@Pankaj Panjiar

I checked that the hostname is correct and it allows the mentioned csv file download.

The only reason i see there that you might have some N/W issue at your end. Please check from the browser if you can download from the same URL:

Please check if you are able to do following? If not then definitely this is related to your N/W setting or the internet access is not allowed from your host.


Or there may be some proxyHost setting on your OS which is restricting some website access.


Its internet that is not working on my sandbox. Tried every network adapter setting possible with no success

Super Collaborator

@Pankaj Panjiar, this looks like a network issue. Can you please restart your VM and retry?

Done that and also tried all the network adapter setting. no success

@Pankaj Panjjar

Are you able to ping your base machine. If yes the put the following entry in file:-

vi /etc/


And then try to ping

I hope this will work for you. 🙂

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.