Support Questions
Find answers, ask questions, and share your expertise

Openssl error upon host registration

Expert Contributor

I'm trying to register hostnames in Ambari but getting the error below. We tried to run yum update openssl but its got the latest version. We tried to run yum - update it didn’t help. I also tried removing the other openssl packages openssl-devel-1.0.1e-42.el6.x86_64, openssl098e-0.9.8e-17.el6.centos.2.x86_64 and restarting the ambari server/agents and same error. Tried running yum -y install opens* as well but didn’t help. Any ideas?

ERROR 2015-09-23 09:47:07,402 NetUtil.py:77 - [Errno 8] _ssl.c:492: EOF occurred in violation of protocol
ERROR 2015-09-23 09:47:07,402 NetUtil.py:78 - SSLError: Failed to connect. Please check openssl library versions.
Refer to: https://bugzilla.redhat.com/show_bug.cgi?id=1022468 for more details.
WARNING 2015-09-23 09:47:07,402 NetUtil.py:105 - Server at https://test.org:8440is not reachable, sleeping for 10 seconds...
WARNING 2015-09-23 09:47:07,402 NetUtil.py:105 - Server at https://test.org:8440is not reachable, sleeping for 10 seconds...
INFO 2015-09-23 09:47:14,746 main.py:74 - loglevel=logging.INFO
INFO 2015-09-23 09:47:14,746 main.py:74 - loglevel=logging.INFO
INFO 2015-09-23 09:47:17,403 NetUtil.py:59 - Connecting to https://test.org:8440/ca
WARNING 2015-09-23 09:47:17,404 NetUtil.py:82 - Failed to connect to https://test.org:8440/ca due to [Errno 111] Connection refused
WARNING 2015-09-23 09:47:17,404 NetUtil.py:105 - Server at https://test.org:8440is not reachable, sleeping for 10 seconds...
WARNING 2015-09-23 09:47:17,404 NetUtil.py:105 - Server at https://test.org:8440is not reachable, sleeping for 10 seconds...
ERROR 2015-09-23 09:47:19,780 main.py:315 - Fatal exception occurred:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ambari_agent/main.py", line 312, in <module>
    main(heartbeat_stop_callback)
  File "/usr/lib/python2.6/site-packages/ambari_agent/main.py", line 248, in main
    stop_agent()
  File "/usr/lib/python2.6/site-packages/ambari_agent/main.py", line 198, in stop_agent
    sys.exit(1)
SystemExit: 1
ERROR 2015-09-23 09:47:19,780 main.py:315 - Fatal exception occurred:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ambari_agent/main.py", line 312, in <module>
    main(heartbeat_stop_callback)
  File "/usr/lib/python2.6/site-packages/ambari_agent/main.py", line 248, in main
    stop_agent()
  File "/usr/lib/python2.6/site-packages/ambari_agent/main.py", line 198, in stop_agent
    sys.exit(1)
SystemExit: 1
1 ACCEPTED SOLUTION

Accepted Solutions

Yes. That is a known issue. Modify Ambari Server's java.home to the standard oracle jdk.

View solution in original post

29 REPLIES 29

What is the jdk being used?

We have noticed issues issues when open jdk 1.7.0 is used with Ambari Server resulted in the ssl issue?

Expert Contributor

I believe its using openjdk 1.7. How do I check this? There are several jdk versions installed on all machines.

Check for the value in ambari.properties file:

java.home=/usr/jdk64/jdk1.8.0_40

jdk.name=jdk-8u40-linux-x64.tar.gz

If there are multiple jdks installed try switching the jdk.

ambari-server setup –j <jdk path>

http://docs.hortonworks.com/HDPDocuments/Ambari-2.1.1.0/bk_Installing_HDP_AMB/content/_setup_options...

Expert Contributor

Got it. It’s using OpenJDK 1.7.0_85. Is this version an issue with HDP 2.3?

Yes. That is a known issue. Modify Ambari Server's java.home to the standard oracle jdk.

View solution in original post

Expert Contributor

that fixed it. Thanks.

New Contributor

Hi,

We are also facing same issue. Even after setting java.home=/usr/jdk64/jdk1.8.0_40 in ambari.properties , it is not resolved.

Is standard oracle jdk path different from this ?

Below are logs snippet from ambari-agent.log ::

ERROR 2015-12-24 18:43:31,604 NetUtil.py:77 - [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:590) ERROR 2015-12-24 18:43:31,604 NetUtil.py:78 - SSLError: Failed to connect. Please check openssl library versions. Refer to: https://bugzilla.redhat.com/show_bug.cgi?id=1022468 for more details.

Contributor

@gaurav sharma I am actually facing the same issue, I have the same SSL error message during the registration. Did you find a solution ?

New Contributor

@Ali Gouta No, we are still trying to figure out the solution.

OpenSSl version in my case is ::

[root@dehdteste7778b54apse01 ~]# rpm -qa | grep openssl

openssl-devel-1.0.1k-13.88.amzn1.x86_64

openssl-1.0.1k-13.88.amzn1.x86_64

Can this be a problem ?