Support Questions

Find answers, ask questions, and share your expertise

Problem with flink( Hortonworks)

New Contributor

Hello! I have problem when I install flink in Hortonworks. Help to solve the problem

Apache Ambari Version 2.4.0.0 Hadoop 2.5

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.5/services/FLINK/package/scripts/flink.py", line 164, in <module>
    Master().execute()
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 280, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.5/services/FLINK/package/scripts/flink.py", line 12, in install
    import params
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.5/services/FLINK/package/scripts/params.py", line 5, in <module>
    from resource_management.libraries.functions.version import format_hdp_stack_version
ImportError: cannot import name format_hdp_stack_version
1 ACCEPTED SOLUTION

New Contributor
3 REPLIES 3

Explorer

I think the Ambari Plugin has been developed and tested against Ambari 2.3. Maybe its not compatible with the latest HDP release anymore. (See also: https://github.com/abajwa-hw/ambari-flink-service)

New Contributor

New Contributor

Had couple of issues:

1 recovering from bad install state: https://community.hortonworks.com/questions/607/how-do-you-remove-a-service-from-hdp-via-ambari.html helped.

2. still had an issue with ImportError: cannot import name format_hdp_stack_version removing that line helps: https://github.com/hananiel/hortonworks-flink

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.